summaryrefslogtreecommitdiffstats
path: root/htpdate
diff options
context:
space:
mode:
Diffstat (limited to 'htpdate')
m---------htpdate25
-rw-r--r--htpdate/.SRCINFO15
-rw-r--r--htpdate/.gitignore4
-rw-r--r--htpdate/PKGBUILD28
-rw-r--r--htpdate/htpdate.service11
5 files changed, 58 insertions, 25 deletions
diff --git a/htpdate b/htpdate
deleted file mode 160000
Subproject 4f382359b7f186a64d591140cf019a002e3dd29
diff --git a/htpdate/.SRCINFO b/htpdate/.SRCINFO
new file mode 100644
index 0000000..ff90fb3
--- /dev/null
+++ b/htpdate/.SRCINFO
@@ -0,0 +1,15 @@
1pkgbase = htpdate
2 pkgdesc = A client for time synchronisation
3 pkgver = 1.2.6
4 pkgrel = 1
5 url = https://github.com/angeloc/htpdate
6 arch = i686
7 arch = x86_64
8 license = GPL2
9 depends = glibc
10 source = htpdate-1.2.6.tar.gz::https://github.com/angeloc/htpdate/archive/v1.2.6.tar.gz
11 source = htpdate.service
12 sha256sums = d2cff522b8f53b00769dcca77d8025b19238ed35d702a4739dc05e387f718909
13 sha256sums = 2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b
14
15pkgname = htpdate
diff --git a/htpdate/.gitignore b/htpdate/.gitignore
new file mode 100644
index 0000000..a41cf30
--- /dev/null
+++ b/htpdate/.gitignore
@@ -0,0 +1,4 @@
1/update
2/htpdate-*.tar.xz
3/pkg/
4/src/
diff --git a/htpdate/PKGBUILD b/htpdate/PKGBUILD
new file mode 100644
index 0000000..9e2d275
--- /dev/null
+++ b/htpdate/PKGBUILD
@@ -0,0 +1,28 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Dominik Schrempf <dominik.schrempf at gmail dot com>
3# Contributor: Jonathan Ryan <jryan at curious-computing dot com>
4# Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb>
5pkgname=htpdate
6pkgver=1.2.6
7pkgrel=1
8pkgdesc="A client for time synchronisation"
9arch=('i686' 'x86_64')
10url="https://github.com/angeloc/htpdate"
11license=(GPL2)
12depends=('glibc')
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
14 "htpdate.service")
15sha256sums=('d2cff522b8f53b00769dcca77d8025b19238ed35d702a4739dc05e387f718909'
16 '2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b')
17
18build() {
19 cd ${pkgname}-${pkgver}
20 make
21}
22
23package() {
24 install -D -m644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service
25 cd ${pkgname}-${pkgver}
26 install -D -m755 htpdate ${pkgdir}/usr/bin/htpdate
27 install -D -m644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8
28}
diff --git a/htpdate/htpdate.service b/htpdate/htpdate.service
new file mode 100644
index 0000000..509b072
--- /dev/null
+++ b/htpdate/htpdate.service
@@ -0,0 +1,11 @@
1[Unit]
2Description=Htpdate daemon
3
4[Service]
5Type=forking
6PIDFile=/run/htpdate.pid
7ExecStart=/usr/bin/htpdate -D -a -s -i /run/htpdate.pid www.linux.org www.freebsd.org ntp.neu.edu.cn www.kernel.org
8
9[Install]
10WantedBy=multi-user.target
11