summaryrefslogtreecommitdiffstats
path: root/htpdate/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'htpdate/PKGBUILD')
-rw-r--r--htpdate/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/htpdate/PKGBUILD b/htpdate/PKGBUILD
new file mode 100644
index 0000000..9e2d275
--- /dev/null
+++ b/htpdate/PKGBUILD
@@ -0,0 +1,28 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Dominik Schrempf <dominik.schrempf at gmail dot com>
3# Contributor: Jonathan Ryan <jryan at curious-computing dot com>
4# Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb>
5pkgname=htpdate
6pkgver=1.2.6
7pkgrel=1
8pkgdesc="A client for time synchronisation"
9arch=('i686' 'x86_64')
10url="https://github.com/angeloc/htpdate"
11license=(GPL2)
12depends=('glibc')
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
14 "htpdate.service")
15sha256sums=('d2cff522b8f53b00769dcca77d8025b19238ed35d702a4739dc05e387f718909'
16 '2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b')
17
18build() {
19 cd ${pkgname}-${pkgver}
20 make
21}
22
23package() {
24 install -D -m644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service
25 cd ${pkgname}-${pkgver}
26 install -D -m755 htpdate ${pkgdir}/usr/bin/htpdate
27 install -D -m644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8
28}