diff options
author | Yigit Sever | 2021-10-29 01:30:24 +0300 |
---|---|---|
committer | Yigit Sever | 2021-10-29 01:30:24 +0300 |
commit | 31d147b20c67d95a9e306d0749200bf964ac42af (patch) | |
tree | b0fbe2bb5aa0fec9983746a91d188643ca93466d /htpdate | |
parent | 4a31e5e0f3442a4a5ec9fba94f7bbc2c88312c69 (diff) | |
download | packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.gz packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.bz2 packages-31d147b20c67d95a9e306d0749200bf964ac42af.zip |
Use actual files instead of submodules
Diffstat (limited to 'htpdate')
m--------- | htpdate | 25 | ||||
-rw-r--r-- | htpdate/.SRCINFO | 15 | ||||
-rw-r--r-- | htpdate/.gitignore | 4 | ||||
-rw-r--r-- | htpdate/PKGBUILD | 28 | ||||
-rw-r--r-- | htpdate/htpdate.service | 11 |
5 files changed, 58 insertions, 25 deletions
diff --git a/htpdate b/htpdate deleted file mode 160000 | |||
Subproject 4f382359b7f186a64d591140cf019a002e3dd29 | |||
diff --git a/htpdate/.SRCINFO b/htpdate/.SRCINFO new file mode 100644 index 0000000..ff90fb3 --- /dev/null +++ b/htpdate/.SRCINFO | |||
@@ -0,0 +1,15 @@ | |||
1 | pkgbase = htpdate | ||
2 | pkgdesc = A client for time synchronisation | ||
3 | pkgver = 1.2.6 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/angeloc/htpdate | ||
6 | arch = i686 | ||
7 | arch = x86_64 | ||
8 | license = GPL2 | ||
9 | depends = glibc | ||
10 | source = htpdate-1.2.6.tar.gz::https://github.com/angeloc/htpdate/archive/v1.2.6.tar.gz | ||
11 | source = htpdate.service | ||
12 | sha256sums = d2cff522b8f53b00769dcca77d8025b19238ed35d702a4739dc05e387f718909 | ||
13 | sha256sums = 2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b | ||
14 | |||
15 | pkgname = htpdate | ||
diff --git a/htpdate/.gitignore b/htpdate/.gitignore new file mode 100644 index 0000000..a41cf30 --- /dev/null +++ b/htpdate/.gitignore | |||
@@ -0,0 +1,4 @@ | |||
1 | /update | ||
2 | /htpdate-*.tar.xz | ||
3 | /pkg/ | ||
4 | /src/ | ||
diff --git a/htpdate/PKGBUILD b/htpdate/PKGBUILD new file mode 100644 index 0000000..9e2d275 --- /dev/null +++ b/htpdate/PKGBUILD | |||
@@ -0,0 +1,28 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Dominik Schrempf <dominik.schrempf at gmail dot com> | ||
3 | # Contributor: Jonathan Ryan <jryan at curious-computing dot com> | ||
4 | # Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb> | ||
5 | pkgname=htpdate | ||
6 | pkgver=1.2.6 | ||
7 | pkgrel=1 | ||
8 | pkgdesc="A client for time synchronisation" | ||
9 | arch=('i686' 'x86_64') | ||
10 | url="https://github.com/angeloc/htpdate" | ||
11 | license=(GPL2) | ||
12 | depends=('glibc') | ||
13 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz" | ||
14 | "htpdate.service") | ||
15 | sha256sums=('d2cff522b8f53b00769dcca77d8025b19238ed35d702a4739dc05e387f718909' | ||
16 | '2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b') | ||
17 | |||
18 | build() { | ||
19 | cd ${pkgname}-${pkgver} | ||
20 | make | ||
21 | } | ||
22 | |||
23 | package() { | ||
24 | install -D -m644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service | ||
25 | cd ${pkgname}-${pkgver} | ||
26 | install -D -m755 htpdate ${pkgdir}/usr/bin/htpdate | ||
27 | install -D -m644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8 | ||
28 | } | ||
diff --git a/htpdate/htpdate.service b/htpdate/htpdate.service new file mode 100644 index 0000000..509b072 --- /dev/null +++ b/htpdate/htpdate.service | |||
@@ -0,0 +1,11 @@ | |||
1 | [Unit] | ||
2 | Description=Htpdate daemon | ||
3 | |||
4 | [Service] | ||
5 | Type=forking | ||
6 | PIDFile=/run/htpdate.pid | ||
7 | ExecStart=/usr/bin/htpdate -D -a -s -i /run/htpdate.pid www.linux.org www.freebsd.org ntp.neu.edu.cn www.kernel.org | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
11 | |||