summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2022-11-27 12:50:28 +0300
committerYigit Sever2022-11-27 12:50:28 +0300
commit7e3373ecd5da7a2004f619a039b621e0d745a99e (patch)
tree27b418499eae912420303b65f995c762d25bf74c /PKGBUILD
parent2a9297138db1a7dc1610e69b5f902b0e62795bb2 (diff)
downloadpackages-7e3373ecd5da7a2004f619a039b621e0d745a99e.tar.gz
packages-7e3373ecd5da7a2004f619a039b621e0d745a99e.tar.bz2
packages-7e3373ecd5da7a2004f619a039b621e0d745a99e.zip
Update to 0.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 26 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9bc3dfd..0641836 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
2 2
3pkgname=ouch-bin 3pkgname=ouch-bin
4_pkgname=${pkgname%-bin} 4_pkgname=${pkgname%-bin}
5pkgver=0.3.1 5pkgver=0.4.0
6pkgrel=1 6pkgrel=1
7pkgdesc="Painless compression and decompression in the terminal (binary release)" 7pkgdesc="Painless compression and decompression in the terminal (binary release)"
8arch=('x86_64') 8arch=('x86_64')
@@ -10,12 +10,31 @@ url="https://github.com/ouch-org/ouch"
10license=('MIT') 10license=('MIT')
11provides=(${_pkgname}) 11provides=(${_pkgname})
12conflicts=(${_pkgname} ${_pkgname}-git) 12conflicts=(${_pkgname} ${_pkgname}-git)
13source=("${_pkgname}::${url}/releases/download/${pkgver}/ouch-x86_64-linux-musl" 13source=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/${pkgver}/ouch-x86_64-unknown-linux-gnu.tar.gz")
14 "LICENSE::https://raw.githubusercontent.com/ouch-org/ouch/master/LICENSE") 14sha256sums=('4b03c6a54b12e2038600cfb450aebac70bd9516fc9bf50a78c93f93fef75e60b')
15sha256sums=('48843b18aee48273e60456267c408163d51df046ad79a6cdd99c75c45cb79afe'
16 'f082ccc8a66b3fdbeb6d53d5fe084934fc6f480a9d1d9243d2c5d9e45ec76938')
17 15
18package() { 16package() {
19 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE" 17 # Binary releaes is archived in a folder with a generic name, it is not ideal
20 install -Dvm755 "${_pkgname}" -t "${pkgdir}/usr/bin" 18 # (e.g. aur helpers will complain about name clashes)
19 # So we fix it
20 cd "${srcdir}"
21 mkdir "${_pkgname}-${pkgver}"
22 mv "${srcdir}/ouch-x86_64-unknown-linux-gnu/"* "${_pkgname}-${pkgver}"
23 rmdir ouch-x86_64-unknown-linux-gnu
24
25 cd "${srcdir}/${_pkgname}-${pkgver}"
26
27 install -Dm0755 -t "${pkgdir}/usr/bin" "${_pkgname}"
28 install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
29
30 # install manpages
31 install -Dm0644 "man/${_pkgname}.1" -t "${pkgdir}/usr/share/man/man1"
32 install -Dm0644 "man/${_pkgname}-compress.1" -t "${pkgdir}/usr/share/man/man1"
33 install -Dm0644 "man/${_pkgname}-decompress.1" -t "${pkgdir}/usr/share/man/man1"
34 install -Dm0644 "man/${_pkgname}-list.1" -t "${pkgdir}/usr/share/man/man1"
35
36 # install shell completions
37 install -Dm0644 "completions/${_pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
38 install -Dm0644 "completions/${_pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${_pkgname}.fish"
39 install -Dm0644 "completions/_${_pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${_pkgname}"
21} 40}