summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2021-11-03 19:51:35 +0300
committerYigit Sever2021-11-03 19:57:46 +0300
commit2a9297138db1a7dc1610e69b5f902b0e62795bb2 (patch)
tree72d6fbd64bf68d117d63735708794be5a691a551 /PKGBUILD
downloadpackages-2a9297138db1a7dc1610e69b5f902b0e62795bb2.tar.gz
packages-2a9297138db1a7dc1610e69b5f902b0e62795bb2.tar.bz2
packages-2a9297138db1a7dc1610e69b5f902b0e62795bb2.zip
Initial commit 0.3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..9bc3dfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=ouch-bin
4_pkgname=${pkgname%-bin}
5pkgver=0.3.1
6pkgrel=1
7pkgdesc="Painless compression and decompression in the terminal (binary release)"
8arch=('x86_64')
9url="https://github.com/ouch-org/ouch"
10license=('MIT')
11provides=(${_pkgname})
12conflicts=(${_pkgname} ${_pkgname}-git)
13source=("${_pkgname}::${url}/releases/download/${pkgver}/ouch-x86_64-linux-musl"
14 "LICENSE::https://raw.githubusercontent.com/ouch-org/ouch/master/LICENSE")
15sha256sums=('48843b18aee48273e60456267c408163d51df046ad79a6cdd99c75c45cb79afe'
16 'f082ccc8a66b3fdbeb6d53d5fe084934fc6f480a9d1d9243d2c5d9e45ec76938')
17
18package() {
19 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
20 install -Dvm755 "${_pkgname}" -t "${pkgdir}/usr/bin"
21}