summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD33
2 files changed, 29 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6247c1d..395e550 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
1pkgbase = ouch-bin 1pkgbase = ouch-bin
2 pkgdesc = Painless compression and decompression in the terminal (binary release) 2 pkgdesc = Painless compression and decompression in the terminal (binary release)
3 pkgver = 0.3.1 3 pkgver = 0.4.0
4 pkgrel = 1 4 pkgrel = 1
5 url = https://github.com/ouch-org/ouch 5 url = https://github.com/ouch-org/ouch
6 arch = x86_64 6 arch = x86_64
@@ -8,9 +8,7 @@ pkgbase = ouch-bin
8 provides = ouch 8 provides = ouch
9 conflicts = ouch 9 conflicts = ouch
10 conflicts = ouch-git 10 conflicts = ouch-git
11 source = ouch::https://github.com/ouch-org/ouch/releases/download/0.3.1/ouch-x86_64-linux-musl 11 source = ouch-0.4.0.tar.gz::https://github.com/ouch-org/ouch/releases/download/0.4.0/ouch-x86_64-unknown-linux-gnu.tar.gz
12 source = LICENSE::https://raw.githubusercontent.com/ouch-org/ouch/master/LICENSE 12 sha256sums = 4b03c6a54b12e2038600cfb450aebac70bd9516fc9bf50a78c93f93fef75e60b
13 sha256sums = 48843b18aee48273e60456267c408163d51df046ad79a6cdd99c75c45cb79afe
14 sha256sums = f082ccc8a66b3fdbeb6d53d5fe084934fc6f480a9d1d9243d2c5d9e45ec76938
15 13
16pkgname = ouch-bin 14pkgname = ouch-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9bc3dfd..0641836 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
2 2
3pkgname=ouch-bin 3pkgname=ouch-bin
4_pkgname=${pkgname%-bin} 4_pkgname=${pkgname%-bin}
5pkgver=0.3.1 5pkgver=0.4.0
6pkgrel=1 6pkgrel=1
7pkgdesc="Painless compression and decompression in the terminal (binary release)" 7pkgdesc="Painless compression and decompression in the terminal (binary release)"
8arch=('x86_64') 8arch=('x86_64')
@@ -10,12 +10,31 @@ url="https://github.com/ouch-org/ouch"
10license=('MIT') 10license=('MIT')
11provides=(${_pkgname}) 11provides=(${_pkgname})
12conflicts=(${_pkgname} ${_pkgname}-git) 12conflicts=(${_pkgname} ${_pkgname}-git)
13source=("${_pkgname}::${url}/releases/download/${pkgver}/ouch-x86_64-linux-musl" 13source=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/${pkgver}/ouch-x86_64-unknown-linux-gnu.tar.gz")
14 "LICENSE::https://raw.githubusercontent.com/ouch-org/ouch/master/LICENSE") 14sha256sums=('4b03c6a54b12e2038600cfb450aebac70bd9516fc9bf50a78c93f93fef75e60b')
15sha256sums=('48843b18aee48273e60456267c408163d51df046ad79a6cdd99c75c45cb79afe'
16 'f082ccc8a66b3fdbeb6d53d5fe084934fc6f480a9d1d9243d2c5d9e45ec76938')
17 15
18package() { 16package() {
19 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE" 17 # Binary releaes is archived in a folder with a generic name, it is not ideal
20 install -Dvm755 "${_pkgname}" -t "${pkgdir}/usr/bin" 18 # (e.g. aur helpers will complain about name clashes)
19 # So we fix it
20 cd "${srcdir}"
21 mkdir "${_pkgname}-${pkgver}"
22 mv "${srcdir}/ouch-x86_64-unknown-linux-gnu/"* "${_pkgname}-${pkgver}"
23 rmdir ouch-x86_64-unknown-linux-gnu
24
25 cd "${srcdir}/${_pkgname}-${pkgver}"
26
27 install -Dm0755 -t "${pkgdir}/usr/bin" "${_pkgname}"
28 install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
29
30 # install manpages
31 install -Dm0644 "man/${_pkgname}.1" -t "${pkgdir}/usr/share/man/man1"
32 install -Dm0644 "man/${_pkgname}-compress.1" -t "${pkgdir}/usr/share/man/man1"
33 install -Dm0644 "man/${_pkgname}-decompress.1" -t "${pkgdir}/usr/share/man/man1"
34 install -Dm0644 "man/${_pkgname}-list.1" -t "${pkgdir}/usr/share/man/man1"
35
36 # install shell completions
37 install -Dm0644 "completions/${_pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
38 install -Dm0644 "completions/${_pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${_pkgname}.fish"
39 install -Dm0644 "completions/_${_pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${_pkgname}"
21} 40}