diff options
Diffstat (limited to 'python-scrape-schema-recipe/PKGBUILD')
-rw-r--r-- | python-scrape-schema-recipe/PKGBUILD | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/python-scrape-schema-recipe/PKGBUILD b/python-scrape-schema-recipe/PKGBUILD new file mode 100644 index 0000000..0c8b57f --- /dev/null +++ b/python-scrape-schema-recipe/PKGBUILD | |||
@@ -0,0 +1,29 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | |||
3 | pkgname=python-scrape-schema-recipe | ||
4 | _pkgname=scrape-schema-recipe | ||
5 | pkgver=0.2.0 | ||
6 | pkgrel=2 | ||
7 | pkgdesc="Scrapes food recipes from HTML into Python dictionaries" | ||
8 | arch=('any') | ||
9 | url="https://github.com/micahcochran/scrape-schema-recipe" | ||
10 | license=('Apache') | ||
11 | depends=('python-dataclasses' | ||
12 | 'python-extruct' | ||
13 | 'python-importlib_resources' | ||
14 | 'python-isodate' | ||
15 | 'python-requests' | ||
16 | 'python-types-requests') | ||
17 | makedepends=('python-setuptools') | ||
18 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz") | ||
19 | sha256sums=('ecc253c82a9346c66e77005680a3f746a2feca7292bbcab0c4357b2757a0d1bf') | ||
20 | |||
21 | build() { | ||
22 | cd "${_pkgname}-${pkgver}" | ||
23 | python setup.py build | ||
24 | } | ||
25 | |||
26 | package() { | ||
27 | cd "${_pkgname}-${pkgver}" | ||
28 | python setup.py install --root="$pkgdir" --optimize=1 | ||
29 | } | ||