summaryrefslogtreecommitdiffstats
path: root/python-scrape-schema-recipe/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2023-12-06 13:44:43 +0300
committerYigit Sever2023-12-06 13:44:43 +0300
commit1499eb3b8b775eeb0d88b31784ae266f675672f2 (patch)
tree5a95b519ea8d539fa1e16b6d1a4a56198d16166f /python-scrape-schema-recipe/PKGBUILD
parent795c2e7658deddc4f963ef6bcd7e971c9db9951f (diff)
parent5dcd5b8e0c9f2febf20c6b6575da130424683218 (diff)
downloadpackages-1499eb3b8b775eeb0d88b31784ae266f675672f2.tar.gz
packages-1499eb3b8b775eeb0d88b31784ae266f675672f2.tar.bz2
packages-1499eb3b8b775eeb0d88b31784ae266f675672f2.zip
Add 'python-scrape-schema-recipe/' from commit '5dcd5b8e0c9f2febf20c6b6575da130424683218'
git-subtree-dir: python-scrape-schema-recipe git-subtree-mainline: 795c2e7658deddc4f963ef6bcd7e971c9db9951f git-subtree-split: 5dcd5b8e0c9f2febf20c6b6575da130424683218
Diffstat (limited to 'python-scrape-schema-recipe/PKGBUILD')
-rw-r--r--python-scrape-schema-recipe/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/python-scrape-schema-recipe/PKGBUILD b/python-scrape-schema-recipe/PKGBUILD
new file mode 100644
index 0000000..0c8b57f
--- /dev/null
+++ b/python-scrape-schema-recipe/PKGBUILD
@@ -0,0 +1,29 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=python-scrape-schema-recipe
4_pkgname=scrape-schema-recipe
5pkgver=0.2.0
6pkgrel=2
7pkgdesc="Scrapes food recipes from HTML into Python dictionaries"
8arch=('any')
9url="https://github.com/micahcochran/scrape-schema-recipe"
10license=('Apache')
11depends=('python-dataclasses'
12 'python-extruct'
13 'python-importlib_resources'
14 'python-isodate'
15 'python-requests'
16 'python-types-requests')
17makedepends=('python-setuptools')
18source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
19sha256sums=('ecc253c82a9346c66e77005680a3f746a2feca7292bbcab0c4357b2757a0d1bf')
20
21build() {
22 cd "${_pkgname}-${pkgver}"
23 python setup.py build
24}
25
26package() {
27 cd "${_pkgname}-${pkgver}"
28 python setup.py install --root="$pkgdir" --optimize=1
29}