diff options
Diffstat (limited to 'py-spy')
-rw-r--r-- | py-spy/.SRCINFO | 14 | ||||
-rw-r--r-- | py-spy/.gitignore | 3 | ||||
-rw-r--r-- | py-spy/PKGBUILD | 25 |
3 files changed, 42 insertions, 0 deletions
diff --git a/py-spy/.SRCINFO b/py-spy/.SRCINFO new file mode 100644 index 0000000..0054d33 --- /dev/null +++ b/py-spy/.SRCINFO | |||
@@ -0,0 +1,14 @@ | |||
1 | pkgbase = py-spy | ||
2 | pkgdesc = Sampling profiler for Python programs | ||
3 | pkgver = 0.4.0 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/benfred/py-spy | ||
6 | arch = x86_64 | ||
7 | license = MIT | ||
8 | makedepends = rust | ||
9 | makedepends = cargo | ||
10 | makedepends = libunwind | ||
11 | source = py-spy-0.4.0.tar.gz::https://github.com/benfred/py-spy/archive/refs/tags/v0.4.0.tar.gz | ||
12 | sha256sums = 13a5c4b949947425670eedac05b6dd27edbc736b75f1587899efca1a7ef79ac3 | ||
13 | |||
14 | pkgname = py-spy | ||
diff --git a/py-spy/.gitignore b/py-spy/.gitignore new file mode 100644 index 0000000..f9e46d0 --- /dev/null +++ b/py-spy/.gitignore | |||
@@ -0,0 +1,3 @@ | |||
1 | *.tar.* | ||
2 | /src | ||
3 | /pkg | ||
diff --git a/py-spy/PKGBUILD b/py-spy/PKGBUILD new file mode 100644 index 0000000..23cb8cf --- /dev/null +++ b/py-spy/PKGBUILD | |||
@@ -0,0 +1,25 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: lilydjwg <lilydjwg@gmail.com> | ||
3 | # Contributor: Clayton Craft <clayton@craftyguy.net> | ||
4 | pkgname=py-spy | ||
5 | pkgver=0.4.0 | ||
6 | pkgrel=1 | ||
7 | pkgdesc="Sampling profiler for Python programs" | ||
8 | arch=('x86_64') | ||
9 | license=('MIT') | ||
10 | url="https://github.com/benfred/py-spy" | ||
11 | makedepends=('rust' 'cargo' 'libunwind') | ||
12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz") | ||
13 | sha256sums=('13a5c4b949947425670eedac05b6dd27edbc736b75f1587899efca1a7ef79ac3') | ||
14 | |||
15 | build() { | ||
16 | cd "${pkgname}-${pkgver}" | ||
17 | cargo build --release | ||
18 | } | ||
19 | |||
20 | package() { | ||
21 | cd "${pkgname}-${pkgver}" | ||
22 | install -Dm755 "target/release/py-spy" "${pkgdir}/usr/bin/py-spy" | ||
23 | install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" | ||
24 | install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md" | ||
25 | } | ||