summaryrefslogtreecommitdiffstats
path: root/py-spy/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'py-spy/PKGBUILD')
-rw-r--r--py-spy/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/py-spy/PKGBUILD b/py-spy/PKGBUILD
new file mode 100644
index 0000000..23cb8cf
--- /dev/null
+++ b/py-spy/PKGBUILD
@@ -0,0 +1,25 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: lilydjwg <lilydjwg@gmail.com>
3# Contributor: Clayton Craft <clayton@craftyguy.net>
4pkgname=py-spy
5pkgver=0.4.0
6pkgrel=1
7pkgdesc="Sampling profiler for Python programs"
8arch=('x86_64')
9license=('MIT')
10url="https://github.com/benfred/py-spy"
11makedepends=('rust' 'cargo' 'libunwind')
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
13sha256sums=('13a5c4b949947425670eedac05b6dd27edbc736b75f1587899efca1a7ef79ac3')
14
15build() {
16 cd "${pkgname}-${pkgver}"
17 cargo build --release
18}
19
20package() {
21 cd "${pkgname}-${pkgver}"
22 install -Dm755 "target/release/py-spy" "${pkgdir}/usr/bin/py-spy"
23 install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
24 install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
25}