diff options
Diffstat (limited to 'htpdate')
-rw-r--r-- | htpdate/.SRCINFO | 16 | ||||
-rw-r--r-- | htpdate/.gitignore | 4 | ||||
-rw-r--r-- | htpdate/PKGBUILD | 29 | ||||
-rw-r--r-- | htpdate/htpdate.service | 11 |
4 files changed, 60 insertions, 0 deletions
diff --git a/htpdate/.SRCINFO b/htpdate/.SRCINFO new file mode 100644 index 0000000..1a58caa --- /dev/null +++ b/htpdate/.SRCINFO | |||
@@ -0,0 +1,16 @@ | |||
1 | pkgbase = htpdate | ||
2 | pkgdesc = HTTP Time protocol | ||
3 | pkgver = 2.0.0 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/twekkel/htpdate | ||
6 | arch = i686 | ||
7 | arch = x86_64 | ||
8 | license = GPL-2.0-or-later | ||
9 | depends = glibc | ||
10 | depends = openssl | ||
11 | source = htpdate-2.0.0.tar.gz::https://github.com/twekkel/htpdate/archive/v2.0.0.tar.gz | ||
12 | source = htpdate.service | ||
13 | sha256sums = 52f25811f00dfe714e0bcf122358ee0ad74e25db3ad230d5a4196e7a62633f27 | ||
14 | sha256sums = 2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b | ||
15 | |||
16 | pkgname = htpdate | ||
diff --git a/htpdate/.gitignore b/htpdate/.gitignore new file mode 100644 index 0000000..aece887 --- /dev/null +++ b/htpdate/.gitignore | |||
@@ -0,0 +1,4 @@ | |||
1 | /update | ||
2 | /htpdate-*.tar.* | ||
3 | /pkg/ | ||
4 | /src/ | ||
diff --git a/htpdate/PKGBUILD b/htpdate/PKGBUILD new file mode 100644 index 0000000..a5177d8 --- /dev/null +++ b/htpdate/PKGBUILD | |||
@@ -0,0 +1,29 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Dominik Schrempf <dominik.schrempf at gmail dot com> | ||
3 | # Contributor: Jonathan Ryan <jryan at curious-computing dot com> | ||
4 | # Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb> | ||
5 | |||
6 | pkgname=htpdate | ||
7 | pkgver=2.0.0 | ||
8 | pkgrel=1 | ||
9 | pkgdesc="HTTP Time protocol" | ||
10 | arch=('i686' 'x86_64') | ||
11 | url="https://github.com/twekkel/htpdate" | ||
12 | license=('GPL-2.0-or-later') | ||
13 | depends=('glibc' 'openssl') | ||
14 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz" | ||
15 | "htpdate.service") | ||
16 | sha256sums=('52f25811f00dfe714e0bcf122358ee0ad74e25db3ad230d5a4196e7a62633f27' | ||
17 | '2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b') | ||
18 | |||
19 | build() { | ||
20 | cd ${pkgname}-${pkgver} | ||
21 | make https | ||
22 | } | ||
23 | |||
24 | package() { | ||
25 | install -D -m644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service | ||
26 | cd ${pkgname}-${pkgver} | ||
27 | install -D -m755 htpdate ${pkgdir}/usr/bin/htpdate | ||
28 | install -D -m644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8 | ||
29 | } | ||
diff --git a/htpdate/htpdate.service b/htpdate/htpdate.service new file mode 100644 index 0000000..509b072 --- /dev/null +++ b/htpdate/htpdate.service | |||
@@ -0,0 +1,11 @@ | |||
1 | [Unit] | ||
2 | Description=Htpdate daemon | ||
3 | |||
4 | [Service] | ||
5 | Type=forking | ||
6 | PIDFile=/run/htpdate.pid | ||
7 | ExecStart=/usr/bin/htpdate -D -a -s -i /run/htpdate.pid www.linux.org www.freebsd.org ntp.neu.edu.cn www.kernel.org | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
11 | |||