summaryrefslogtreecommitdiffstats
path: root/htpdate/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'htpdate/PKGBUILD')
-rw-r--r--htpdate/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/htpdate/PKGBUILD b/htpdate/PKGBUILD
new file mode 100644
index 0000000..a5177d8
--- /dev/null
+++ b/htpdate/PKGBUILD
@@ -0,0 +1,29 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Dominik Schrempf <dominik.schrempf at gmail dot com>
3# Contributor: Jonathan Ryan <jryan at curious-computing dot com>
4# Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb>
5
6pkgname=htpdate
7pkgver=2.0.0
8pkgrel=1
9pkgdesc="HTTP Time protocol"
10arch=('i686' 'x86_64')
11url="https://github.com/twekkel/htpdate"
12license=('GPL-2.0-or-later')
13depends=('glibc' 'openssl')
14source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
15 "htpdate.service")
16sha256sums=('52f25811f00dfe714e0bcf122358ee0ad74e25db3ad230d5a4196e7a62633f27'
17 '2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b')
18
19build() {
20 cd ${pkgname}-${pkgver}
21 make https
22}
23
24package() {
25 install -D -m644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service
26 cd ${pkgname}-${pkgver}
27 install -D -m755 htpdate ${pkgdir}/usr/bin/htpdate
28 install -D -m644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8
29}