summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27a3311..0f8ad8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
1pkgbase = wapiti 1pkgbase = wapiti
2 pkgdesc = Comprehensive web app vulnerability scanner written in Python 2 pkgdesc = Comprehensive web app vulnerability scanner written in Python
3 pkgver = 3.0.9 3 pkgver = 3.1.0
4 pkgrel = 1 4 pkgrel = 1
5 url = https://wapiti-scanner.github.io 5 url = https://wapiti-scanner.github.io
6 changelog = ChangeLog 6 changelog = ChangeLog
@@ -17,13 +17,12 @@ pkgbase = wapiti
17 depends = python-python-socks 17 depends = python-python-socks
18 depends = python-tld 18 depends = python-tld
19 depends = python-httpx 19 depends = python-httpx
20 depends = python-httpx-socks
21 depends = python-aiocache 20 depends = python-aiocache
22 depends = python-sqlalchemy 21 depends = python-sqlalchemy
23 optdepends = python-requests-kerberos: Kerberos authentication 22 optdepends = python-requests-kerberos: Kerberos authentication
24 optdepends = python-requests-ntlm: NTLM authentication 23 optdepends = python-requests-ntlm: NTLM authentication
25 options = zipman 24 options = zipman
26 source = https://downloads.sourceforge.net/sourceforge/wapiti/wapiti/wapiti-3.0.9/wapiti3-3.0.9.tar.gz 25 source = https://github.com/wapiti-scanner/wapiti/releases/download/3.1.0/wapiti3-3.1.0.tar.gz
27 sha256sums = bd64674b9152057bf1534ca7d7aab8cad4fccb1027813e0d0281f48823a82475 26 sha256sums = 4974204e5da966c3e91946465840420c708c034a7c030c5597d3c36badf05a0f
28 27
29pkgname = wapiti 28pkgname = wapiti
diff --git a/PKGBUILD b/PKGBUILD
index 5c52fc1..dee5188 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
4 4
5pkgname=wapiti 5pkgname=wapiti
6 6
7pkgver=3.0.9 7pkgver=3.1.0
8_name="$pkgname${pkgver:0:1}" 8_name="$pkgname${pkgver:0:1}"
9pkgrel=1 9pkgrel=1
10 10
@@ -15,16 +15,17 @@ license=('GPL')
15 15
16makedepends=('python-setuptools' 'python-pip') 16makedepends=('python-setuptools' 'python-pip')
17depends=('python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-yaswfp' 'python-browser-cookie3' 17depends=('python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-yaswfp' 'python-browser-cookie3'
18 'python-mako' 'python-python-socks' 'python-tld' 'python-httpx' 'python-httpx-socks' 18 'python-mako' 'python-python-socks' 'python-tld' 'python-httpx' 'python-aiocache'
19 'python-aiocache' 'python-sqlalchemy') 19 'python-sqlalchemy')
20optdepends=('python-requests-kerberos: Kerberos authentication' 20optdepends=('python-requests-kerberos: Kerberos authentication'
21 'python-requests-ntlm: NTLM authentication') 21 'python-requests-ntlm: NTLM authentication')
22 22
23options=('zipman') 23options=('zipman')
24 24
25changelog=ChangeLog 25changelog=ChangeLog
26source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$_name-$pkgver.tar.gz") 26source=("https://github.com/$pkgname-scanner/$pkgname/releases/download/$pkgver/$_name-$pkgver.tar.gz")
27sha256sums=('bd64674b9152057bf1534ca7d7aab8cad4fccb1027813e0d0281f48823a82475') 27#source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$_name-$pkgver.tar.gz")
28sha256sums=('4974204e5da966c3e91946465840420c708c034a7c030c5597d3c36badf05a0f')
28 29
29 30
30prepare() { rm -rf "$_name-$pkgver/tests"; } 31prepare() { rm -rf "$_name-$pkgver/tests"; }