diff options
-rw-r--r-- | quich/.SRCINFO | 13 | ||||
-rw-r--r-- | quich/.gitignore | 4 | ||||
-rw-r--r-- | quich/PKGBUILD | 23 |
3 files changed, 40 insertions, 0 deletions
diff --git a/quich/.SRCINFO b/quich/.SRCINFO new file mode 100644 index 0000000..ba0c813 --- /dev/null +++ b/quich/.SRCINFO | |||
@@ -0,0 +1,13 @@ | |||
1 | pkgbase = quich | ||
2 | pkgdesc = Small, fast and useful calculator for your terminal with multiple functions and options. | ||
3 | pkgver = 3.0.0 | ||
4 | pkgrel = 2 | ||
5 | url = https://github.com/Usbac/quich | ||
6 | arch = x86_64 | ||
7 | license = MIT | ||
8 | provides = quich | ||
9 | source = https://github.com/Usbac/quich/archive/v3.0.0/quich-3.0.0.tar.gz | ||
10 | md5sums = 1528086998d28739ed3e573d08c23d3c | ||
11 | |||
12 | pkgname = quich | ||
13 | |||
diff --git a/quich/.gitignore b/quich/.gitignore new file mode 100644 index 0000000..75cb413 --- /dev/null +++ b/quich/.gitignore | |||
@@ -0,0 +1,4 @@ | |||
1 | src/ | ||
2 | pkg/ | ||
3 | *.tar.xz | ||
4 | *.tar.gz | ||
diff --git a/quich/PKGBUILD b/quich/PKGBUILD new file mode 100644 index 0000000..8e70a51 --- /dev/null +++ b/quich/PKGBUILD | |||
@@ -0,0 +1,23 @@ | |||
1 | # Maintainer: vscncls <lucaslou4@protonmail.com> | ||
2 | |||
3 | pkgname=quich | ||
4 | pkgver=3.0.0 | ||
5 | pkgrel=2 | ||
6 | pkgdesc="Small, fast and useful calculator for your terminal with multiple functions and options." | ||
7 | url="https://github.com/Usbac/quich" | ||
8 | arch=('x86_64') | ||
9 | license=('MIT') | ||
10 | provides=("$pkgname") | ||
11 | source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz") | ||
12 | md5sums=('1528086998d28739ed3e573d08c23d3c') | ||
13 | |||
14 | build() { | ||
15 | cd $pkgname-$pkgver | ||
16 | NAME=$pkgname make quich | ||
17 | } | ||
18 | |||
19 | package() { | ||
20 | install -Dm755 $pkgname-$pkgver/$pkgname $pkgdir/usr/bin/$pkgname | ||
21 | |||
22 | install -Dm644 $pkgname-$pkgver/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE | ||
23 | } | ||