diff options
author | Yigit Sever | 2024-03-29 00:36:29 +0300 |
---|---|---|
committer | Yigit Sever | 2024-03-29 00:36:29 +0300 |
commit | b0e0fb0166d76ac3be6622fd803a83a2ceecb3f5 (patch) | |
tree | c871cbeb4eef9d61c3b9bec4855b0b8770b4b35b /python-scrape-schema-recipe/PKGBUILD | |
parent | 8d50bb91876244e59dd0bc799002457727caca94 (diff) | |
parent | cb915cf6fcb4d2d44226056ed9bb503db2a1e56f (diff) | |
download | packages-b0e0fb0166d76ac3be6622fd803a83a2ceecb3f5.tar.gz packages-b0e0fb0166d76ac3be6622fd803a83a2ceecb3f5.tar.bz2 packages-b0e0fb0166d76ac3be6622fd803a83a2ceecb3f5.zip |
Add 'python-scrape-schema-recipe/' from commit 'cb915cf6fcb4d2d44226056ed9bb503db2a1e56f'
git-subtree-dir: python-scrape-schema-recipe
git-subtree-mainline: 8d50bb91876244e59dd0bc799002457727caca94
git-subtree-split: cb915cf6fcb4d2d44226056ed9bb503db2a1e56f
Diffstat (limited to 'python-scrape-schema-recipe/PKGBUILD')
-rw-r--r-- | python-scrape-schema-recipe/PKGBUILD | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/python-scrape-schema-recipe/PKGBUILD b/python-scrape-schema-recipe/PKGBUILD new file mode 100644 index 0000000..3d98efd --- /dev/null +++ b/python-scrape-schema-recipe/PKGBUILD | |||
@@ -0,0 +1,29 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | |||
3 | pkgname=python-scrape-schema-recipe | ||
4 | _pkgname=scrape-schema-recipe | ||
5 | pkgver=0.2.2 | ||
6 | pkgrel=1 | ||
7 | pkgdesc="Scrapes food recipes from HTML into Python dictionaries" | ||
8 | arch=('any') | ||
9 | url="https://github.com/micahcochran/scrape-schema-recipe" | ||
10 | license=('Apache') | ||
11 | depends=('python-dataclasses' | ||
12 | 'python-extruct' | ||
13 | 'python-importlib_resources' | ||
14 | 'python-isodate' | ||
15 | 'python-requests' | ||
16 | 'python-types-requests') | ||
17 | makedepends=('python-setuptools') | ||
18 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz") | ||
19 | sha256sums=('aa4004fedb52019d9d627944b03966412b3dda8a96df06c0715aa0889af07216') | ||
20 | |||
21 | build() { | ||
22 | cd "${_pkgname}-${pkgver}" | ||
23 | python setup.py build | ||
24 | } | ||
25 | |||
26 | package() { | ||
27 | cd "${_pkgname}-${pkgver}" | ||
28 | python setup.py install --root="$pkgdir" --optimize=1 | ||
29 | } | ||