aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2024-03-29 00:36:29 +0300
committerYigit Sever2024-03-29 00:36:29 +0300
commitb0e0fb0166d76ac3be6622fd803a83a2ceecb3f5 (patch)
treec871cbeb4eef9d61c3b9bec4855b0b8770b4b35b
parent8d50bb91876244e59dd0bc799002457727caca94 (diff)
parentcb915cf6fcb4d2d44226056ed9bb503db2a1e56f (diff)
downloadpackages-b0e0fb0166d76ac3be6622fd803a83a2ceecb3f5.tar.gz
packages-b0e0fb0166d76ac3be6622fd803a83a2ceecb3f5.tar.bz2
packages-b0e0fb0166d76ac3be6622fd803a83a2ceecb3f5.zip
Add 'python-scrape-schema-recipe/' from commit 'cb915cf6fcb4d2d44226056ed9bb503db2a1e56f'
git-subtree-dir: python-scrape-schema-recipe git-subtree-mainline: 8d50bb91876244e59dd0bc799002457727caca94 git-subtree-split: cb915cf6fcb4d2d44226056ed9bb503db2a1e56f
-rw-r--r--python-scrape-schema-recipe/.SRCINFO18
-rw-r--r--python-scrape-schema-recipe/PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/python-scrape-schema-recipe/.SRCINFO b/python-scrape-schema-recipe/.SRCINFO
new file mode 100644
index 0000000..ac54e91
--- /dev/null
+++ b/python-scrape-schema-recipe/.SRCINFO
@@ -0,0 +1,18 @@
1pkgbase = python-scrape-schema-recipe
2 pkgdesc = Scrapes food recipes from HTML into Python dictionaries
3 pkgver = 0.2.2
4 pkgrel = 1
5 url = https://github.com/micahcochran/scrape-schema-recipe
6 arch = any
7 license = Apache
8 makedepends = python-setuptools
9 depends = python-dataclasses
10 depends = python-extruct
11 depends = python-importlib_resources
12 depends = python-isodate
13 depends = python-requests
14 depends = python-types-requests
15 source = python-scrape-schema-recipe-0.2.2.tar.gz::https://github.com/micahcochran/scrape-schema-recipe/archive/v0.2.2.tar.gz
16 sha256sums = aa4004fedb52019d9d627944b03966412b3dda8a96df06c0715aa0889af07216
17
18pkgname = python-scrape-schema-recipe
diff --git a/python-scrape-schema-recipe/PKGBUILD b/python-scrape-schema-recipe/PKGBUILD
new file mode 100644
index 0000000..3d98efd
--- /dev/null
+++ b/python-scrape-schema-recipe/PKGBUILD
@@ -0,0 +1,29 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=python-scrape-schema-recipe
4_pkgname=scrape-schema-recipe
5pkgver=0.2.2
6pkgrel=1
7pkgdesc="Scrapes food recipes from HTML into Python dictionaries"
8arch=('any')
9url="https://github.com/micahcochran/scrape-schema-recipe"
10license=('Apache')
11depends=('python-dataclasses'
12 'python-extruct'
13 'python-importlib_resources'
14 'python-isodate'
15 'python-requests'
16 'python-types-requests')
17makedepends=('python-setuptools')
18source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
19sha256sums=('aa4004fedb52019d9d627944b03966412b3dda8a96df06c0715aa0889af07216')
20
21build() {
22 cd "${_pkgname}-${pkgver}"
23 python setup.py build
24}
25
26package() {
27 cd "${_pkgname}-${pkgver}"
28 python setup.py install --root="$pkgdir" --optimize=1
29}