summaryrefslogtreecommitdiffstats
path: root/python-pyrdfa3/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2021-10-29 01:30:24 +0300
committerYigit Sever2021-10-29 01:30:24 +0300
commit31d147b20c67d95a9e306d0749200bf964ac42af (patch)
treeb0fbe2bb5aa0fec9983746a91d188643ca93466d /python-pyrdfa3/PKGBUILD
parent4a31e5e0f3442a4a5ec9fba94f7bbc2c88312c69 (diff)
downloadpackages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.gz
packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.bz2
packages-31d147b20c67d95a9e306d0749200bf964ac42af.zip
Use actual files instead of submodules
Diffstat (limited to 'python-pyrdfa3/PKGBUILD')
-rw-r--r--python-pyrdfa3/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/python-pyrdfa3/PKGBUILD b/python-pyrdfa3/PKGBUILD
new file mode 100644
index 0000000..cf2ebac
--- /dev/null
+++ b/python-pyrdfa3/PKGBUILD
@@ -0,0 +1,24 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2pkgname=python-pyrdfa3
3_pkgname=pyrdfa3
4pkgver=3.5.2
5pkgrel=1
6pkgdesc="Python distiller/parser library"
7arch=('any')
8url="https://github.com/RDFLib/pyrdfa3"
9license=('custom')
10depends=('python-rdflib' 'python-html5lib' 'python-simplejson' 'python-isodate')
11makedepends=('python-setuptools')
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
13sha256sums=('2cf88994c9726eae043d24c2b6945ec2d0bf5c417e29dfd86cb5170884015905')
14
15build() {
16 cd "${_pkgname}-${pkgver}"
17 python setup.py build
18}
19
20package() {
21 cd "${_pkgname}-${pkgver}"
22 python setup.py install --root="$pkgdir" --optimize=1
23 install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
24}