summaryrefslogtreecommitdiffstats
path: root/python-pyrdfa3
diff options
context:
space:
mode:
authorYigit Sever2021-10-29 01:30:24 +0300
committerYigit Sever2021-10-29 01:30:24 +0300
commit31d147b20c67d95a9e306d0749200bf964ac42af (patch)
treeb0fbe2bb5aa0fec9983746a91d188643ca93466d /python-pyrdfa3
parent4a31e5e0f3442a4a5ec9fba94f7bbc2c88312c69 (diff)
downloadpackages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.gz
packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.bz2
packages-31d147b20c67d95a9e306d0749200bf964ac42af.zip
Use actual files instead of submodules
Diffstat (limited to 'python-pyrdfa3')
m---------python-pyrdfa30
-rw-r--r--python-pyrdfa3/.SRCINFO16
-rw-r--r--python-pyrdfa3/PKGBUILD24
3 files changed, 40 insertions, 0 deletions
diff --git a/python-pyrdfa3 b/python-pyrdfa3
deleted file mode 160000
Subproject 16141ed512e31aeef2a11f4999b184be8a4dd5b
diff --git a/python-pyrdfa3/.SRCINFO b/python-pyrdfa3/.SRCINFO
new file mode 100644
index 0000000..52a8625
--- /dev/null
+++ b/python-pyrdfa3/.SRCINFO
@@ -0,0 +1,16 @@
1pkgbase = python-pyrdfa3
2 pkgdesc = Python distiller/parser library
3 pkgver = 3.5.2
4 pkgrel = 1
5 url = https://github.com/RDFLib/pyrdfa3
6 arch = any
7 license = custom
8 makedepends = python-setuptools
9 depends = python-rdflib
10 depends = python-html5lib
11 depends = python-simplejson
12 depends = python-isodate
13 source = python-pyrdfa3-3.5.2.tar.gz::https://github.com/RDFLib/pyrdfa3/archive/3.5.2.tar.gz
14 sha256sums = 2cf88994c9726eae043d24c2b6945ec2d0bf5c417e29dfd86cb5170884015905
15
16pkgname = python-pyrdfa3
diff --git a/python-pyrdfa3/PKGBUILD b/python-pyrdfa3/PKGBUILD
new file mode 100644
index 0000000..cf2ebac
--- /dev/null
+++ b/python-pyrdfa3/PKGBUILD
@@ -0,0 +1,24 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2pkgname=python-pyrdfa3
3_pkgname=pyrdfa3
4pkgver=3.5.2
5pkgrel=1
6pkgdesc="Python distiller/parser library"
7arch=('any')
8url="https://github.com/RDFLib/pyrdfa3"
9license=('custom')
10depends=('python-rdflib' 'python-html5lib' 'python-simplejson' 'python-isodate')
11makedepends=('python-setuptools')
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
13sha256sums=('2cf88994c9726eae043d24c2b6945ec2d0bf5c417e29dfd86cb5170884015905')
14
15build() {
16 cd "${_pkgname}-${pkgver}"
17 python setup.py build
18}
19
20package() {
21 cd "${_pkgname}-${pkgver}"
22 python setup.py install --root="$pkgdir" --optimize=1
23 install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
24}