diff options
author | Yigit Sever | 2021-10-29 01:30:24 +0300 |
---|---|---|
committer | Yigit Sever | 2021-10-29 01:30:24 +0300 |
commit | 31d147b20c67d95a9e306d0749200bf964ac42af (patch) | |
tree | b0fbe2bb5aa0fec9983746a91d188643ca93466d /python-extruct/PKGBUILD | |
parent | 4a31e5e0f3442a4a5ec9fba94f7bbc2c88312c69 (diff) | |
download | packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.gz packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.bz2 packages-31d147b20c67d95a9e306d0749200bf964ac42af.zip |
Use actual files instead of submodules
Diffstat (limited to 'python-extruct/PKGBUILD')
-rw-r--r-- | python-extruct/PKGBUILD | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/python-extruct/PKGBUILD b/python-extruct/PKGBUILD new file mode 100644 index 0000000..3aaf859 --- /dev/null +++ b/python-extruct/PKGBUILD | |||
@@ -0,0 +1,24 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | pkgname=python-extruct | ||
3 | _pkgname=extruct | ||
4 | pkgver=0.13.0 | ||
5 | pkgrel=1 | ||
6 | pkgdesc="Extract embedded metadata from HTML markup" | ||
7 | arch=('any') | ||
8 | url="https://github.com/scrapinghub/extruct" | ||
9 | license=('custom') | ||
10 | depends=('python-lxml' 'python-requests' 'python-rdflib' 'python-rdflib-jsonld' 'python-pyrdfa3' 'python-mf2py' 'python-six' 'python-w3lib' 'python-html-text' 'python-jstyleson') | ||
11 | makedepends=('python-setuptools') | ||
12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz") | ||
13 | sha256sums=('2bf4d8aaf9cfd2ea27bac256e5cabd601a480a47f49b9531ac8bfe3b42a9c74f') | ||
14 | |||
15 | build() { | ||
16 | cd "${_pkgname}-${pkgver}" | ||
17 | python setup.py build | ||
18 | } | ||
19 | |||
20 | package() { | ||
21 | cd "${_pkgname}-${pkgver}" | ||
22 | python setup.py install --root="$pkgdir" --optimize=1 | ||
23 | install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/" | ||
24 | } | ||