summaryrefslogtreecommitdiffstats
path: root/python-extruct
diff options
context:
space:
mode:
authorYigit Sever2021-10-29 01:30:24 +0300
committerYigit Sever2021-10-29 01:30:24 +0300
commit31d147b20c67d95a9e306d0749200bf964ac42af (patch)
treeb0fbe2bb5aa0fec9983746a91d188643ca93466d /python-extruct
parent4a31e5e0f3442a4a5ec9fba94f7bbc2c88312c69 (diff)
downloadpackages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.gz
packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.bz2
packages-31d147b20c67d95a9e306d0749200bf964ac42af.zip
Use actual files instead of submodules
Diffstat (limited to 'python-extruct')
m---------python-extruct22
-rw-r--r--python-extruct/.SRCINFO22
-rw-r--r--python-extruct/PKGBUILD24
3 files changed, 46 insertions, 22 deletions
diff --git a/python-extruct b/python-extruct
deleted file mode 160000
Subproject b0607877ea6354b47e359d8b602df1791be0979
diff --git a/python-extruct/.SRCINFO b/python-extruct/.SRCINFO
new file mode 100644
index 0000000..2a808e7
--- /dev/null
+++ b/python-extruct/.SRCINFO
@@ -0,0 +1,22 @@
1pkgbase = python-extruct
2 pkgdesc = Extract embedded metadata from HTML markup
3 pkgver = 0.13.0
4 pkgrel = 1
5 url = https://github.com/scrapinghub/extruct
6 arch = any
7 license = custom
8 makedepends = python-setuptools
9 depends = python-lxml
10 depends = python-requests
11 depends = python-rdflib
12 depends = python-rdflib-jsonld
13 depends = python-pyrdfa3
14 depends = python-mf2py
15 depends = python-six
16 depends = python-w3lib
17 depends = python-html-text
18 depends = python-jstyleson
19 source = python-extruct-0.13.0.tar.gz::https://github.com/scrapinghub/extruct/archive/v0.13.0.tar.gz
20 sha256sums = 2bf4d8aaf9cfd2ea27bac256e5cabd601a480a47f49b9531ac8bfe3b42a9c74f
21
22pkgname = python-extruct
diff --git a/python-extruct/PKGBUILD b/python-extruct/PKGBUILD
new file mode 100644
index 0000000..3aaf859
--- /dev/null
+++ b/python-extruct/PKGBUILD
@@ -0,0 +1,24 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2pkgname=python-extruct
3_pkgname=extruct
4pkgver=0.13.0
5pkgrel=1
6pkgdesc="Extract embedded metadata from HTML markup"
7arch=('any')
8url="https://github.com/scrapinghub/extruct"
9license=('custom')
10depends=('python-lxml' 'python-requests' 'python-rdflib' 'python-rdflib-jsonld' 'python-pyrdfa3' 'python-mf2py' 'python-six' 'python-w3lib' 'python-html-text' 'python-jstyleson')
11makedepends=('python-setuptools')
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
13sha256sums=('2bf4d8aaf9cfd2ea27bac256e5cabd601a480a47f49b9531ac8bfe3b42a9c74f')
14
15build() {
16 cd "${_pkgname}-${pkgver}"
17 python setup.py build
18}
19
20package() {
21 cd "${_pkgname}-${pkgver}"
22 python setup.py install --root="$pkgdir" --optimize=1
23 install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
24}