diff options
author | Yigit Sever | 2021-10-29 01:30:24 +0300 |
---|---|---|
committer | Yigit Sever | 2021-10-29 01:30:24 +0300 |
commit | 31d147b20c67d95a9e306d0749200bf964ac42af (patch) | |
tree | b0fbe2bb5aa0fec9983746a91d188643ca93466d /osh | |
parent | 4a31e5e0f3442a4a5ec9fba94f7bbc2c88312c69 (diff) | |
download | packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.gz packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.bz2 packages-31d147b20c67d95a9e306d0749200bf964ac42af.zip |
Use actual files instead of submodules
Diffstat (limited to 'osh')
m--------- | osh | 0 | ||||
-rw-r--r-- | osh/.SRCINFO | 13 | ||||
-rw-r--r-- | osh/PKGBUILD | 32 |
3 files changed, 45 insertions, 0 deletions
diff --git a/osh b/osh deleted file mode 160000 | |||
Subproject 32d84760cb091b121a71194a4da7a70281d6464 | |||
diff --git a/osh/.SRCINFO b/osh/.SRCINFO new file mode 100644 index 0000000..05350fa --- /dev/null +++ b/osh/.SRCINFO | |||
@@ -0,0 +1,13 @@ | |||
1 | pkgbase = osh | ||
2 | pkgdesc = Oil Shell - A bash-compatible UNIX shell written in Python | ||
3 | pkgver = 0.9.3 | ||
4 | pkgrel = 1 | ||
5 | url = https://www.oilshell.org/ | ||
6 | arch = any | ||
7 | license = Apache | ||
8 | optdepends = readline: interactive features | ||
9 | options = !strip | ||
10 | source = https://www.oilshell.org/download/oil-0.9.3.tar.xz | ||
11 | sha256sums = 62f36072f69f3378e03b79d8d5255c1d136094ec11410db4f16ee82f1660efda | ||
12 | |||
13 | pkgname = osh | ||
diff --git a/osh/PKGBUILD b/osh/PKGBUILD new file mode 100644 index 0000000..11a757f --- /dev/null +++ b/osh/PKGBUILD | |||
@@ -0,0 +1,32 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Qontinuum <qontinuum@artixlinux.org> | ||
3 | # Contributor: timetoplatypus <timetoplatypus@protonmail.com> | ||
4 | # Contributor: andychu <andy@oilshell.org> | ||
5 | |||
6 | pkgname=osh | ||
7 | pkgver=0.9.3 | ||
8 | pkgrel=1 | ||
9 | pkgdesc="Oil Shell - A bash-compatible UNIX shell written in Python" | ||
10 | arch=('any') | ||
11 | url="https://www.oilshell.org/" | ||
12 | license=("Apache") | ||
13 | options=(!strip) | ||
14 | optdepends=("readline: interactive features") | ||
15 | source=("https://www.oilshell.org/download/oil-$pkgver.tar.xz") | ||
16 | sha256sums=('62f36072f69f3378e03b79d8d5255c1d136094ec11410db4f16ee82f1660efda') | ||
17 | |||
18 | prepare() { | ||
19 | mkdir -p tmp | ||
20 | sed 's/TMP=${TMPDIR:-\/tmp}/TMP=..\/tmp/' -i "oil-$pkgver/configure" | ||
21 | } | ||
22 | |||
23 | build() { | ||
24 | cd "oil-$pkgver" | ||
25 | ./configure --prefix="/usr" | ||
26 | make $MAKEFLAGS | ||
27 | } | ||
28 | |||
29 | package() { | ||
30 | cd "oil-$pkgver" | ||
31 | DESTDIR="$pkgdir/" ./install | ||
32 | } | ||