diff options
Diffstat (limited to 'osh/PKGBUILD')
-rw-r--r-- | osh/PKGBUILD | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/osh/PKGBUILD b/osh/PKGBUILD new file mode 100644 index 0000000..11a757f --- /dev/null +++ b/osh/PKGBUILD | |||
@@ -0,0 +1,32 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Qontinuum <qontinuum@artixlinux.org> | ||
3 | # Contributor: timetoplatypus <timetoplatypus@protonmail.com> | ||
4 | # Contributor: andychu <andy@oilshell.org> | ||
5 | |||
6 | pkgname=osh | ||
7 | pkgver=0.9.3 | ||
8 | pkgrel=1 | ||
9 | pkgdesc="Oil Shell - A bash-compatible UNIX shell written in Python" | ||
10 | arch=('any') | ||
11 | url="https://www.oilshell.org/" | ||
12 | license=("Apache") | ||
13 | options=(!strip) | ||
14 | optdepends=("readline: interactive features") | ||
15 | source=("https://www.oilshell.org/download/oil-$pkgver.tar.xz") | ||
16 | sha256sums=('62f36072f69f3378e03b79d8d5255c1d136094ec11410db4f16ee82f1660efda') | ||
17 | |||
18 | prepare() { | ||
19 | mkdir -p tmp | ||
20 | sed 's/TMP=${TMPDIR:-\/tmp}/TMP=..\/tmp/' -i "oil-$pkgver/configure" | ||
21 | } | ||
22 | |||
23 | build() { | ||
24 | cd "oil-$pkgver" | ||
25 | ./configure --prefix="/usr" | ||
26 | make $MAKEFLAGS | ||
27 | } | ||
28 | |||
29 | package() { | ||
30 | cd "oil-$pkgver" | ||
31 | DESTDIR="$pkgdir/" ./install | ||
32 | } | ||