diff options
author | Yigit Sever | 2022-12-19 21:16:18 +0300 |
---|---|---|
committer | Yigit Sever | 2022-12-19 21:16:18 +0300 |
commit | a77f84f7cc785006dbd6d5cf68277f194dbac3b4 (patch) | |
tree | 9ecadd3d5ecccc7f408ae2e721fe97420f3c0019 /gourmand/PKGBUILD | |
parent | 78f5fcae5e0abc325e1290cd94cf30050b31f159 (diff) | |
parent | 904ab220ae5765d1aec333f90e183a91a5e488ab (diff) | |
download | packages-a77f84f7cc785006dbd6d5cf68277f194dbac3b4.tar.gz packages-a77f84f7cc785006dbd6d5cf68277f194dbac3b4.tar.bz2 packages-a77f84f7cc785006dbd6d5cf68277f194dbac3b4.zip |
Add 'gourmand/' from commit '904ab220ae5765d1aec333f90e183a91a5e488ab'
git-subtree-dir: gourmand
git-subtree-mainline: 78f5fcae5e0abc325e1290cd94cf30050b31f159
git-subtree-split: 904ab220ae5765d1aec333f90e183a91a5e488ab
Diffstat (limited to 'gourmand/PKGBUILD')
-rw-r--r-- | gourmand/PKGBUILD | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/gourmand/PKGBUILD b/gourmand/PKGBUILD new file mode 100644 index 0000000..92e52c9 --- /dev/null +++ b/gourmand/PKGBUILD | |||
@@ -0,0 +1,37 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | |||
3 | pkgname='gourmand' | ||
4 | pkgver=1.0.0 | ||
5 | pkgrel=3 | ||
6 | pkgdesc="A recipe manager for desktop that can import recipes" | ||
7 | arch=('any') | ||
8 | url="https://github.com/GourmandRecipeManager/gourmand" | ||
9 | license=('GPL') | ||
10 | depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy' 'python-lxml' 'python-cairo' 'python-requests') | ||
11 | makedepends=('python-pip' 'gendesk') | ||
12 | checkdepends=() | ||
13 | optdepends=( | ||
14 | 'python-beautifulsoup4: Webpage import plugin' | ||
15 | 'python-scrape-schema-recipe: Webpage import plugin' | ||
16 | 'python-selenium' | ||
17 | 'python-keyring' | ||
18 | 'python-ebooklib: EPub export plugin' | ||
19 | 'python-reportlab: Printing & PDF export plugin' | ||
20 | 'python-gtkspellcheck: Spell checking plugin' | ||
21 | 'nuspell: Spell checking' | ||
22 | 'hspell: Spell checking for Hebrew' | ||
23 | 'libvoikko: Spell checking for Finnish language' | ||
24 | ) | ||
25 | conflicts=('gourmet') | ||
26 | source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl") | ||
27 | sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4') | ||
28 | |||
29 | prepare() { | ||
30 | gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" | ||
31 | } | ||
32 | |||
33 | package() { | ||
34 | # https://wiki.archlinux.org/title/Python_package_guidelines#pip | ||
35 | PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl | ||
36 | install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop" | ||
37 | } | ||