summaryrefslogtreecommitdiffstats
path: root/gourmand/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2022-12-19 21:16:09 +0300
committerYigit Sever2022-12-19 21:16:09 +0300
commit78f5fcae5e0abc325e1290cd94cf30050b31f159 (patch)
treec0998993027e4b93e924b37e6f77b5f52cadd737 /gourmand/PKGBUILD
parentbef6099f0df4de8d16343f9cb7d3490268fa4f49 (diff)
downloadpackages-78f5fcae5e0abc325e1290cd94cf30050b31f159.tar.gz
packages-78f5fcae5e0abc325e1290cd94cf30050b31f159.tar.bz2
packages-78f5fcae5e0abc325e1290cd94cf30050b31f159.zip
Deleted package: gourmand
Diffstat (limited to 'gourmand/PKGBUILD')
-rw-r--r--gourmand/PKGBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/gourmand/PKGBUILD b/gourmand/PKGBUILD
deleted file mode 100644
index 92e52c9..0000000
--- a/gourmand/PKGBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname='gourmand'
4pkgver=1.0.0
5pkgrel=3
6pkgdesc="A recipe manager for desktop that can import recipes"
7arch=('any')
8url="https://github.com/GourmandRecipeManager/gourmand"
9license=('GPL')
10depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy' 'python-lxml' 'python-cairo' 'python-requests')
11makedepends=('python-pip' 'gendesk')
12checkdepends=()
13optdepends=(
14 'python-beautifulsoup4: Webpage import plugin'
15 'python-scrape-schema-recipe: Webpage import plugin'
16 'python-selenium'
17 'python-keyring'
18 'python-ebooklib: EPub export plugin'
19 'python-reportlab: Printing & PDF export plugin'
20 'python-gtkspellcheck: Spell checking plugin'
21 'nuspell: Spell checking'
22 'hspell: Spell checking for Hebrew'
23 'libvoikko: Spell checking for Finnish language'
24 )
25conflicts=('gourmet')
26source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl")
27sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4')
28
29prepare() {
30 gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc"
31}
32
33package() {
34 # https://wiki.archlinux.org/title/Python_package_guidelines#pip
35 PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
36 install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
37}