summaryrefslogtreecommitdiffstats
path: root/dvc/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2021-11-16 15:56:06 +0300
committerYigit Sever2021-11-16 15:56:06 +0300
commit5f672acc55ffe9d72c39d76f4bc1ae8ec6539067 (patch)
treee397ba75937e9fe569b57cc736cdd5fdda14a112 /dvc/PKGBUILD
parentb12b893ba2ae85b42c9a370dcf8885fe2755734c (diff)
downloadpackages-5f672acc55ffe9d72c39d76f4bc1ae8ec6539067.tar.gz
packages-5f672acc55ffe9d72c39d76f4bc1ae8ec6539067.tar.bz2
packages-5f672acc55ffe9d72c39d76f4bc1ae8ec6539067.zip
Tracking adopted packages
- dvc - flowy - ouch{-bin, -git,}
Diffstat (limited to 'dvc/PKGBUILD')
-rw-r--r--dvc/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/dvc/PKGBUILD b/dvc/PKGBUILD
new file mode 100644
index 0000000..baa792d
--- /dev/null
+++ b/dvc/PKGBUILD
@@ -0,0 +1,40 @@
1# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
2# Contributor: Lex Black <autumn-wind@web.de>
3# Contributor: Mr. Outis <mroutis@protonmail.com>
4
5pkgname=dvc
6pkgver=2.8.3
7pkgrel=1
8pkgdesc="Open-source version control system for data science projects"
9arch=('any')
10license=('Apache')
11url="https://github.com/iterative/${pkgname}"
12depends=('python' 'python-appdirs' 'python-colorama' 'python-configobj'
13 'python-distro' 'python-flufl-lock' 'python-funcy' 'python-gitdb'
14 'python-gitpython' 'python-humanize' 'python-inflect'
15 'python-packaging' 'python-pathspec' 'python-ply' 'python-pyasn1'
16 'python-yaml' 'python-requests' 'python-ruamel-yaml'
17 'python-setuptools' 'python-shortuuid' 'python-tqdm'
18 'python-treelib' 'python-voluptuous' 'python-zc.lockfile'
19 'python-nanotime' 'python-grandalf' 'python-ntfs' 'python-shtab'
20 'python-pygtrie'
21)
22optdepends=('python-google-cloud-storage: support for Google Cloud'
23 'python-google-api-python-client: support for GDrive'
24 'python-pydrive: support for GDrive'
25 'python-boto3: support for AWS S3 remote'
26 'python-paramiko: support for SSH remote'
27 'python-azure-storage: support for Azure remote'
28 'python-oss2: support for Aliyun Object Storage Service (OSS)'
29 'python-pyarrow: support for HDFS remote'
30 )
31makedepends=('git')
32
33source=("git+${url}/#commit=4175f9ffa4948157436283bef11153a7233e90ca")
34sha256sums=('SKIP')
35
36package() {
37 cd ${pkgname}
38 python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
39}
40