diff options
author | Yigit Sever | 2021-11-16 15:56:06 +0300 |
---|---|---|
committer | Yigit Sever | 2021-11-16 15:56:06 +0300 |
commit | 5f672acc55ffe9d72c39d76f4bc1ae8ec6539067 (patch) | |
tree | e397ba75937e9fe569b57cc736cdd5fdda14a112 /dvc | |
parent | b12b893ba2ae85b42c9a370dcf8885fe2755734c (diff) | |
download | packages-5f672acc55ffe9d72c39d76f4bc1ae8ec6539067.tar.gz packages-5f672acc55ffe9d72c39d76f4bc1ae8ec6539067.tar.bz2 packages-5f672acc55ffe9d72c39d76f4bc1ae8ec6539067.zip |
Tracking adopted packages
- dvc
- flowy
- ouch{-bin, -git,}
Diffstat (limited to 'dvc')
-rw-r--r-- | dvc/.SRCINFO | 49 | ||||
-rw-r--r-- | dvc/PKGBUILD | 40 |
2 files changed, 89 insertions, 0 deletions
diff --git a/dvc/.SRCINFO b/dvc/.SRCINFO new file mode 100644 index 0000000..955e60f --- /dev/null +++ b/dvc/.SRCINFO | |||
@@ -0,0 +1,49 @@ | |||
1 | pkgbase = dvc | ||
2 | pkgdesc = Open-source version control system for data science projects | ||
3 | pkgver = 2.8.3 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/iterative/dvc | ||
6 | arch = any | ||
7 | license = Apache | ||
8 | makedepends = git | ||
9 | depends = python | ||
10 | depends = python-appdirs | ||
11 | depends = python-colorama | ||
12 | depends = python-configobj | ||
13 | depends = python-distro | ||
14 | depends = python-flufl-lock | ||
15 | depends = python-funcy | ||
16 | depends = python-gitdb | ||
17 | depends = python-gitpython | ||
18 | depends = python-humanize | ||
19 | depends = python-inflect | ||
20 | depends = python-packaging | ||
21 | depends = python-pathspec | ||
22 | depends = python-ply | ||
23 | depends = python-pyasn1 | ||
24 | depends = python-yaml | ||
25 | depends = python-requests | ||
26 | depends = python-ruamel-yaml | ||
27 | depends = python-setuptools | ||
28 | depends = python-shortuuid | ||
29 | depends = python-tqdm | ||
30 | depends = python-treelib | ||
31 | depends = python-voluptuous | ||
32 | depends = python-zc.lockfile | ||
33 | depends = python-nanotime | ||
34 | depends = python-grandalf | ||
35 | depends = python-ntfs | ||
36 | depends = python-shtab | ||
37 | depends = python-pygtrie | ||
38 | optdepends = python-google-cloud-storage: support for Google Cloud | ||
39 | optdepends = python-google-api-python-client: support for GDrive | ||
40 | optdepends = python-pydrive: support for GDrive | ||
41 | optdepends = python-boto3: support for AWS S3 remote | ||
42 | optdepends = python-paramiko: support for SSH remote | ||
43 | optdepends = python-azure-storage: support for Azure remote | ||
44 | optdepends = python-oss2: support for Aliyun Object Storage Service (OSS) | ||
45 | optdepends = python-pyarrow: support for HDFS remote | ||
46 | source = git+https://github.com/iterative/dvc/#commit=4175f9ffa4948157436283bef11153a7233e90ca | ||
47 | sha256sums = SKIP | ||
48 | |||
49 | pkgname = dvc | ||
diff --git a/dvc/PKGBUILD b/dvc/PKGBUILD new file mode 100644 index 0000000..baa792d --- /dev/null +++ b/dvc/PKGBUILD | |||
@@ -0,0 +1,40 @@ | |||
1 | # Maintainer: Stefan Husmann <stefan-husmann@t-online.de> | ||
2 | # Contributor: Lex Black <autumn-wind@web.de> | ||
3 | # Contributor: Mr. Outis <mroutis@protonmail.com> | ||
4 | |||
5 | pkgname=dvc | ||
6 | pkgver=2.8.3 | ||
7 | pkgrel=1 | ||
8 | pkgdesc="Open-source version control system for data science projects" | ||
9 | arch=('any') | ||
10 | license=('Apache') | ||
11 | url="https://github.com/iterative/${pkgname}" | ||
12 | depends=('python' 'python-appdirs' 'python-colorama' 'python-configobj' | ||
13 | 'python-distro' 'python-flufl-lock' 'python-funcy' 'python-gitdb' | ||
14 | 'python-gitpython' 'python-humanize' 'python-inflect' | ||
15 | 'python-packaging' 'python-pathspec' 'python-ply' 'python-pyasn1' | ||
16 | 'python-yaml' 'python-requests' 'python-ruamel-yaml' | ||
17 | 'python-setuptools' 'python-shortuuid' 'python-tqdm' | ||
18 | 'python-treelib' 'python-voluptuous' 'python-zc.lockfile' | ||
19 | 'python-nanotime' 'python-grandalf' 'python-ntfs' 'python-shtab' | ||
20 | 'python-pygtrie' | ||
21 | ) | ||
22 | optdepends=('python-google-cloud-storage: support for Google Cloud' | ||
23 | 'python-google-api-python-client: support for GDrive' | ||
24 | 'python-pydrive: support for GDrive' | ||
25 | 'python-boto3: support for AWS S3 remote' | ||
26 | 'python-paramiko: support for SSH remote' | ||
27 | 'python-azure-storage: support for Azure remote' | ||
28 | 'python-oss2: support for Aliyun Object Storage Service (OSS)' | ||
29 | 'python-pyarrow: support for HDFS remote' | ||
30 | ) | ||
31 | makedepends=('git') | ||
32 | |||
33 | source=("git+${url}/#commit=4175f9ffa4948157436283bef11153a7233e90ca") | ||
34 | sha256sums=('SKIP') | ||
35 | |||
36 | package() { | ||
37 | cd ${pkgname} | ||
38 | python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 | ||
39 | } | ||
40 | |||