diff options
author | ricardofunke | 2015-06-21 11:39:32 -0300 |
---|---|---|
committer | ricardofunke | 2015-06-21 11:39:32 -0300 |
commit | c31fcf2dcf98aab82ce456681c197a5d7861d80c (patch) | |
tree | 8f3f8f2bba55e389d27c2517a6d886e962ae8f30 /PKGBUILD | |
download | packages-c31fcf2dcf98aab82ce456681c197a5d7861d80c.tar.gz packages-c31fcf2dcf98aab82ce456681c197a5d7861d80c.tar.bz2 packages-c31fcf2dcf98aab82ce456681c197a5d7861d80c.zip |
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD new file mode 100644 index 0000000..d581031 --- /dev/null +++ b/PKGBUILD | |||
@@ -0,0 +1,63 @@ | |||
1 | # Maintainer: Ricardo Funke <ricardo [at] gmail [dot] com> | ||
2 | # Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu> | ||
3 | # Contributor: Iwan Timmer <irtimmer [at] gmail [dot] com> | ||
4 | # Contributor: Eric Engestrom <aur [at] engestrom [dot] ch> | ||
5 | # Contributor: Ricardo Band <me [at] xengi [dot] de> | ||
6 | # Contributor: Axilleas Pipinellis (aka axil42) <axilleas [at] archlinux [dot] info> | ||
7 | # Contributor: UshakovVasilii <UshakovVasilii [at] yahoo [dot] com> | ||
8 | # Contributor: Giulio Fidente <gfidente [at] gmail [dot] com> | ||
9 | # Contributor: xantares <xantares09 [at] hotmail [dot] com> | ||
10 | |||
11 | pkgname=popcorntime-bin | ||
12 | pkgver=0.3.7.2 | ||
13 | pkgrel=3 | ||
14 | pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch." | ||
15 | arch=('x86_64' 'i686') | ||
16 | url="http://popcorntime.io/" | ||
17 | license=('GPL3') | ||
18 | depends=('ttf-liberation' 'gconf' 'nss' 'libxtst' 'gtk2' 'alsa-lib') | ||
19 | optdepends=('net-tools: necessary for the new vpn feature') | ||
20 | provides=('popcorntime') | ||
21 | conflicts=('popcorntime') | ||
22 | options=('!strip') | ||
23 | install="popcorntime.install" | ||
24 | sha256sums=('0b294d08e6bc46d3d06717d4a6344b4e6e4e14f742f61101b8498d931d99a952' | ||
25 | '9e1bc552bb06446689233b1a123d4cc421771673a7b803a980d4149bf4dc38b3' | ||
26 | 'ac2b7183d3ea62ae821c7d1f4b243b0ca41c7838efa16babe29cad0c4958ee25' | ||
27 | '3dd794302ad0b3a98d48973175b6de9bc632181872df2d0376a19a5cc0aa14a2') | ||
28 | |||
29 | _platform=Linux64 | ||
30 | |||
31 | if [ "$CARCH" = 'i686' ]; then | ||
32 | _platform=Linux32 | ||
33 | sha256sums[0]='21e5dbc667f13572fcd8edc535ce4fcd2c0bffafcd237753ad8a2f1cc665e1b7' | ||
34 | fi | ||
35 | |||
36 | source=("http://get.popcorntime.io/build/Popcorn-Time-${pkgver}-${_platform}.tar.xz" | ||
37 | "icon.png" | ||
38 | "popcorntime.install" | ||
39 | "popcorntime.desktop") | ||
40 | |||
41 | package() { | ||
42 | cd "${srcdir}" | ||
43 | |||
44 | install -dm755 "${pkgdir}/opt/${pkgname}/" | ||
45 | install -dm755 "${pkgdir}/usr/bin" | ||
46 | install -dm755 "${pkgdir}/usr/share" | ||
47 | |||
48 | # Program | ||
49 | echo "${pkgdir}/opt/${pkgname}/" | ||
50 | install -Dm755 ${srcdir}/Popcorn-Time "${pkgdir}/opt/${pkgname}/" | ||
51 | install -Dm644 ${srcdir}/nw.pak "${pkgdir}/opt/${pkgname}/" | ||
52 | install -Dm644 ${srcdir}/libffmpegsumo.so "${pkgdir}/opt/${pkgname}/" | ||
53 | install -Dm644 ${srcdir}/package.nw "${pkgdir}/opt/${pkgname}/" | ||
54 | |||
55 | # Link to program | ||
56 | ln -s "/opt/${pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/popcorntime" | ||
57 | |||
58 | # Desktop file | ||
59 | install -Dm644 "${srcdir}/popcorntime.desktop" "${pkgdir}/usr/share/applications/popcorntime.desktop" | ||
60 | |||
61 | # Icon | ||
62 | install -Dm644 "${srcdir}/icon.png" "${pkgdir}/usr/share/pixmaps/popcorntime.png" | ||
63 | } | ||