diff options
author | ricardofunke | 2015-06-21 11:39:32 -0300 |
---|---|---|
committer | ricardofunke | 2015-06-21 11:39:32 -0300 |
commit | c31fcf2dcf98aab82ce456681c197a5d7861d80c (patch) | |
tree | 8f3f8f2bba55e389d27c2517a6d886e962ae8f30 | |
download | packages-c31fcf2dcf98aab82ce456681c197a5d7861d80c.tar.gz packages-c31fcf2dcf98aab82ce456681c197a5d7861d80c.tar.bz2 packages-c31fcf2dcf98aab82ce456681c197a5d7861d80c.zip |
Initial import
-rw-r--r-- | .SRCINFO | 30 | ||||
-rw-r--r-- | PKGBUILD | 63 | ||||
-rw-r--r-- | icon.png | bin | 0 -> 81183 bytes | |||
-rw-r--r-- | popcorntime.desktop | 8 | ||||
-rw-r--r-- | popcorntime.install | 13 |
5 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO new file mode 100644 index 0000000..9d163a9 --- /dev/null +++ b/.SRCINFO | |||
@@ -0,0 +1,30 @@ | |||
1 | pkgbase = popcorntime-bin | ||
2 | pkgdesc = Stream movies from torrents. Skip the downloads. Launch, click, watch. | ||
3 | pkgver = 0.3.7.2 | ||
4 | pkgrel = 3 | ||
5 | url = http://popcorntime.io/ | ||
6 | install = popcorntime.install | ||
7 | arch = x86_64 | ||
8 | arch = i686 | ||
9 | license = GPL3 | ||
10 | depends = ttf-liberation | ||
11 | depends = gconf | ||
12 | depends = nss | ||
13 | depends = libxtst | ||
14 | depends = gtk2 | ||
15 | depends = alsa-lib | ||
16 | optdepends = net-tools: necessary for the new vpn feature | ||
17 | provides = popcorntime | ||
18 | conflicts = popcorntime | ||
19 | options = !strip | ||
20 | source = http://get.popcorntime.io/build/Popcorn-Time-0.3.7.2-Linux64.tar.xz | ||
21 | source = icon.png | ||
22 | source = popcorntime.install | ||
23 | source = popcorntime.desktop | ||
24 | sha256sums = 0b294d08e6bc46d3d06717d4a6344b4e6e4e14f742f61101b8498d931d99a952 | ||
25 | sha256sums = 9e1bc552bb06446689233b1a123d4cc421771673a7b803a980d4149bf4dc38b3 | ||
26 | sha256sums = ac2b7183d3ea62ae821c7d1f4b243b0ca41c7838efa16babe29cad0c4958ee25 | ||
27 | sha256sums = 3dd794302ad0b3a98d48973175b6de9bc632181872df2d0376a19a5cc0aa14a2 | ||
28 | |||
29 | pkgname = popcorntime-bin | ||
30 | |||
diff --git a/PKGBUILD b/PKGBUILD new file mode 100644 index 0000000..d581031 --- /dev/null +++ b/PKGBUILD | |||
@@ -0,0 +1,63 @@ | |||
1 | # Maintainer: Ricardo Funke <ricardo [at] gmail [dot] com> | ||
2 | # Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu> | ||
3 | # Contributor: Iwan Timmer <irtimmer [at] gmail [dot] com> | ||
4 | # Contributor: Eric Engestrom <aur [at] engestrom [dot] ch> | ||
5 | # Contributor: Ricardo Band <me [at] xengi [dot] de> | ||
6 | # Contributor: Axilleas Pipinellis (aka axil42) <axilleas [at] archlinux [dot] info> | ||
7 | # Contributor: UshakovVasilii <UshakovVasilii [at] yahoo [dot] com> | ||
8 | # Contributor: Giulio Fidente <gfidente [at] gmail [dot] com> | ||
9 | # Contributor: xantares <xantares09 [at] hotmail [dot] com> | ||
10 | |||
11 | pkgname=popcorntime-bin | ||
12 | pkgver=0.3.7.2 | ||
13 | pkgrel=3 | ||
14 | pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch." | ||
15 | arch=('x86_64' 'i686') | ||
16 | url="http://popcorntime.io/" | ||
17 | license=('GPL3') | ||
18 | depends=('ttf-liberation' 'gconf' 'nss' 'libxtst' 'gtk2' 'alsa-lib') | ||
19 | optdepends=('net-tools: necessary for the new vpn feature') | ||
20 | provides=('popcorntime') | ||
21 | conflicts=('popcorntime') | ||
22 | options=('!strip') | ||
23 | install="popcorntime.install" | ||
24 | sha256sums=('0b294d08e6bc46d3d06717d4a6344b4e6e4e14f742f61101b8498d931d99a952' | ||
25 | '9e1bc552bb06446689233b1a123d4cc421771673a7b803a980d4149bf4dc38b3' | ||
26 | 'ac2b7183d3ea62ae821c7d1f4b243b0ca41c7838efa16babe29cad0c4958ee25' | ||
27 | '3dd794302ad0b3a98d48973175b6de9bc632181872df2d0376a19a5cc0aa14a2') | ||
28 | |||
29 | _platform=Linux64 | ||
30 | |||
31 | if [ "$CARCH" = 'i686' ]; then | ||
32 | _platform=Linux32 | ||
33 | sha256sums[0]='21e5dbc667f13572fcd8edc535ce4fcd2c0bffafcd237753ad8a2f1cc665e1b7' | ||
34 | fi | ||
35 | |||
36 | source=("http://get.popcorntime.io/build/Popcorn-Time-${pkgver}-${_platform}.tar.xz" | ||
37 | "icon.png" | ||
38 | "popcorntime.install" | ||
39 | "popcorntime.desktop") | ||
40 | |||
41 | package() { | ||
42 | cd "${srcdir}" | ||
43 | |||
44 | install -dm755 "${pkgdir}/opt/${pkgname}/" | ||
45 | install -dm755 "${pkgdir}/usr/bin" | ||
46 | install -dm755 "${pkgdir}/usr/share" | ||
47 | |||
48 | # Program | ||
49 | echo "${pkgdir}/opt/${pkgname}/" | ||
50 | install -Dm755 ${srcdir}/Popcorn-Time "${pkgdir}/opt/${pkgname}/" | ||
51 | install -Dm644 ${srcdir}/nw.pak "${pkgdir}/opt/${pkgname}/" | ||
52 | install -Dm644 ${srcdir}/libffmpegsumo.so "${pkgdir}/opt/${pkgname}/" | ||
53 | install -Dm644 ${srcdir}/package.nw "${pkgdir}/opt/${pkgname}/" | ||
54 | |||
55 | # Link to program | ||
56 | ln -s "/opt/${pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/popcorntime" | ||
57 | |||
58 | # Desktop file | ||
59 | install -Dm644 "${srcdir}/popcorntime.desktop" "${pkgdir}/usr/share/applications/popcorntime.desktop" | ||
60 | |||
61 | # Icon | ||
62 | install -Dm644 "${srcdir}/icon.png" "${pkgdir}/usr/share/pixmaps/popcorntime.png" | ||
63 | } | ||
diff --git a/icon.png b/icon.png new file mode 100644 index 0000000..3ea5010 --- /dev/null +++ b/icon.png | |||
Binary files differ | |||
diff --git a/popcorntime.desktop b/popcorntime.desktop new file mode 100644 index 0000000..f8f223b --- /dev/null +++ b/popcorntime.desktop | |||
@@ -0,0 +1,8 @@ | |||
1 | [Desktop Entry] | ||
2 | Name=Popcorn Time | ||
3 | Comment=Watch torrent movies instantly | ||
4 | Exec=popcorntime %U | ||
5 | Icon=popcorntime | ||
6 | Terminal=false | ||
7 | Type=Application | ||
8 | Categories=Player;Video;Network; | ||
diff --git a/popcorntime.install b/popcorntime.install new file mode 100644 index 0000000..55a36e4 --- /dev/null +++ b/popcorntime.install | |||
@@ -0,0 +1,13 @@ | |||
1 | post_install() { | ||
2 | echo | ||
3 | echo "WARNING: Popcorn Time streams movies from Torrents" | ||
4 | echo "Downloading copyrighted material may be illegal in your country!" | ||
5 | echo "Use at your own risk!" | ||
6 | echo | ||
7 | } | ||
8 | |||
9 | post_upgrade() { | ||
10 | post_install | ||
11 | } | ||
12 | |||
13 | # vim:set ts=2 sw=2 et: | ||