summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2021-09-29 15:17:35 +0300
committerYigit Sever2021-09-29 17:22:28 +0300
commita25f40767d4589f4ea0c17c8841fde4d38619b86 (patch)
tree51c74a4e5f4f8d4b0e4ad9456fff63053f4a14bf /PKGBUILD
downloadpackages-a25f40767d4589f4ea0c17c8841fde4d38619b86.tar.gz
packages-a25f40767d4589f4ea0c17c8841fde4d38619b86.tar.bz2
packages-a25f40767d4589f4ea0c17c8841fde4d38619b86.zip
Initial commit v0.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..c1e894a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2pkgname=python-scrape-schema-recipe
3_pkgname=scrape-schema-recipe
4pkgver=0.2.0
5pkgrel=1
6pkgdesc="Scrapes food recipes from HTML into Python dictionaries"
7arch=('any')
8url="https://github.com/micahcochran/scrape-schema-recipe"
9license=('Apache')
10depends=('python-dataclasses' 'python-extruct' 'python-importlib_resources' 'python-isodate' 'python-requests' 'python-typeshed-git')
11makedepends=('python-setuptools')
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
13sha256sums=('ecc253c82a9346c66e77005680a3f746a2feca7292bbcab0c4357b2757a0d1bf')
14
15build() {
16 cd "${_pkgname}-${pkgver}"
17 python setup.py build
18}
19
20package() {
21 cd "${_pkgname}-${pkgver}"
22 python setup.py install --root="$pkgdir" --optimize=1
23}