diff options
-rw-r--r-- | .SRCINFO | 18 | ||||
-rw-r--r-- | PKGBUILD | 23 |
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO new file mode 100644 index 0000000..c05e8eb --- /dev/null +++ b/.SRCINFO | |||
@@ -0,0 +1,18 @@ | |||
1 | pkgbase = python-scrape-schema-recipe | ||
2 | pkgdesc = Scrapes food recipes from HTML into Python dictionaries | ||
3 | pkgver = 0.2.0 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/micahcochran/scrape-schema-recipe | ||
6 | arch = any | ||
7 | license = Apache | ||
8 | makedepends = python-setuptools | ||
9 | depends = python-dataclasses | ||
10 | depends = python-extruct | ||
11 | depends = python-importlib_resources | ||
12 | depends = python-isodate | ||
13 | depends = python-requests | ||
14 | depends = python-typeshed-git | ||
15 | source = python-scrape-schema-recipe-0.2.0.tar.gz::https://github.com/micahcochran/scrape-schema-recipe/archive/v0.2.0.tar.gz | ||
16 | sha256sums = ecc253c82a9346c66e77005680a3f746a2feca7292bbcab0c4357b2757a0d1bf | ||
17 | |||
18 | pkgname = python-scrape-schema-recipe | ||
diff --git a/PKGBUILD b/PKGBUILD new file mode 100644 index 0000000..c1e894a --- /dev/null +++ b/PKGBUILD | |||
@@ -0,0 +1,23 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | pkgname=python-scrape-schema-recipe | ||
3 | _pkgname=scrape-schema-recipe | ||
4 | pkgver=0.2.0 | ||
5 | pkgrel=1 | ||
6 | pkgdesc="Scrapes food recipes from HTML into Python dictionaries" | ||
7 | arch=('any') | ||
8 | url="https://github.com/micahcochran/scrape-schema-recipe" | ||
9 | license=('Apache') | ||
10 | depends=('python-dataclasses' 'python-extruct' 'python-importlib_resources' 'python-isodate' 'python-requests' 'python-typeshed-git') | ||
11 | makedepends=('python-setuptools') | ||
12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz") | ||
13 | sha256sums=('ecc253c82a9346c66e77005680a3f746a2feca7292bbcab0c4357b2757a0d1bf') | ||
14 | |||
15 | build() { | ||
16 | cd "${_pkgname}-${pkgver}" | ||
17 | python setup.py build | ||
18 | } | ||
19 | |||
20 | package() { | ||
21 | cd "${_pkgname}-${pkgver}" | ||
22 | python setup.py install --root="$pkgdir" --optimize=1 | ||
23 | } | ||