diff options
author | Yigit Sever | 2021-09-24 18:24:25 +0300 |
---|---|---|
committer | Yigit Sever | 2021-09-24 18:25:00 +0300 |
commit | 7a5c8b4b2e7ca16722c49c6c0abdb5c754fb5165 (patch) | |
tree | 6adf35dd30923a8ebfe731bd66eb3d19e223f250 /PKGBUILD | |
download | packages-7a5c8b4b2e7ca16722c49c6c0abdb5c754fb5165.tar.gz packages-7a5c8b4b2e7ca16722c49c6c0abdb5c754fb5165.tar.bz2 packages-7a5c8b4b2e7ca16722c49c6c0abdb5c754fb5165.zip |
Initial commit v1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 23 |
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD new file mode 100644 index 0000000..e80e628 --- /dev/null +++ b/PKGBUILD | |||
@@ -0,0 +1,23 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | |||
3 | pkgname='gourmand' | ||
4 | pkgver=1.0.0 | ||
5 | pkgrel=1 | ||
6 | pkgdesc="A recipe manager for desktop with the possibilities to import, organize, and tweak recipes" | ||
7 | arch=('any') | ||
8 | url="https://github.com/GourmandRecipeManager/gourmand" | ||
9 | license=('GPL') | ||
10 | depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy') | ||
11 | makedepends=('python-pip') | ||
12 | checkdepends=() | ||
13 | optdepends=('python-beautifulsoup4: Webpage import plugin') | ||
14 | provides=("${pkgname}") | ||
15 | conflicts=('gourmet') | ||
16 | source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl") | ||
17 | sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4') | ||
18 | |||
19 | package() { | ||
20 | # https://wiki.archlinux.org/title/Python_package_guidelines#pip | ||
21 | PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl | ||
22 | } | ||
23 | # vim:set ts=2 sw=2 et: | ||