diff options
-rw-r--r-- | .SRCINFO | 21 | ||||
-rw-r--r-- | PKGBUILD | 23 |
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO new file mode 100644 index 0000000..812d886 --- /dev/null +++ b/.SRCINFO | |||
@@ -0,0 +1,21 @@ | |||
1 | pkgbase = gourmand | ||
2 | pkgdesc = A recipe manager for desktop with the possibilities to import, organize, and tweak recipes | ||
3 | pkgver = 1.0.0 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/GourmandRecipeManager/gourmand | ||
6 | arch = any | ||
7 | license = GPL | ||
8 | makedepends = python-pip | ||
9 | depends = python-gobject | ||
10 | depends = gtk3 | ||
11 | depends = python-pyenchant | ||
12 | depends = gst-python | ||
13 | depends = python-pillow | ||
14 | depends = python-sqlalchemy | ||
15 | optdepends = python-beautifulsoup4: Webpage import plugin | ||
16 | provides = gourmand | ||
17 | conflicts = gourmet | ||
18 | source = gourmand-1.0.0-py3-none-any.whl::https://github.com/GourmandRecipeManager/gourmand/releases/download/1.0.0/gourmand-1.0.0-py3-none-any.whl | ||
19 | sha256sums = 9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4 | ||
20 | |||
21 | pkgname = gourmand | ||
diff --git a/PKGBUILD b/PKGBUILD new file mode 100644 index 0000000..e80e628 --- /dev/null +++ b/PKGBUILD | |||
@@ -0,0 +1,23 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | |||
3 | pkgname='gourmand' | ||
4 | pkgver=1.0.0 | ||
5 | pkgrel=1 | ||
6 | pkgdesc="A recipe manager for desktop with the possibilities to import, organize, and tweak recipes" | ||
7 | arch=('any') | ||
8 | url="https://github.com/GourmandRecipeManager/gourmand" | ||
9 | license=('GPL') | ||
10 | depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy') | ||
11 | makedepends=('python-pip') | ||
12 | checkdepends=() | ||
13 | optdepends=('python-beautifulsoup4: Webpage import plugin') | ||
14 | provides=("${pkgname}") | ||
15 | conflicts=('gourmet') | ||
16 | source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl") | ||
17 | sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4') | ||
18 | |||
19 | package() { | ||
20 | # https://wiki.archlinux.org/title/Python_package_guidelines#pip | ||
21 | PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl | ||
22 | } | ||
23 | # vim:set ts=2 sw=2 et: | ||