summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-11-14 12:58:56 +1300
committercaltlgin2020-11-14 12:58:56 +1300
commit463986858db228ccd96b7a5f46504df350f65253 (patch)
treee49e4af690d95393a4947b0c4b513cb71df6ca52 /PKGBUILD
downloadpackages-463986858db228ccd96b7a5f46504df350f65253.tar.gz
packages-463986858db228ccd96b7a5f46504df350f65253.tar.bz2
packages-463986858db228ccd96b7a5f46504df350f65253.zip
Add to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..4c4736a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
1# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
2
3pkgname='dnsx'
4pkgver=1.0.0
5pkgrel=1
6pkgdesc='Fast and multi-purpose DNS toolkit'
7arch=('x86_64')
8url='https://github.com/projectdiscovery/dnsx'
9license=('MIT')
10makedepends=('go')
11provides=("${pkgname}")
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
13sha256sums=('112f81c2e5efc73103bebfb9e8f7db0c7e7e9a95ba432625a5469cfe0a104d06')
14
15prepare() {
16 export GOPATH="${srcdir}/gopath"
17 go clean -modcache
18}
19
20build() {
21 export CGO_CPPFLAGS="${CPPFLAGS}"
22 export CGO_CFLAGS="${CFLAGS}"
23 export CGO_CXXFLAGS="${CXXFLAGS}"
24 #export CGO_LDFLAGS="${LDFLAGS}"
25 export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
26
27 cd "${pkgname}-${pkgver}/cmd/${pkgname}"
28 go build -v -o "${pkgname}" .
29}
30
31package() {
32 cd "${pkgname}-${pkgver}"
33 install -Dvm755 "cmd/${pkgname}/${pkgname}" -t "${pkgdir}/usr/bin"
34 install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
35 install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
36}
37
38# vim: ts=2 sw=2 et: