diff options
author | caltlgin | 2020-11-14 12:58:56 +1300 |
---|---|---|
committer | caltlgin | 2020-11-14 12:58:56 +1300 |
commit | 463986858db228ccd96b7a5f46504df350f65253 (patch) | |
tree | e49e4af690d95393a4947b0c4b513cb71df6ca52 | |
download | packages-463986858db228ccd96b7a5f46504df350f65253.tar.gz packages-463986858db228ccd96b7a5f46504df350f65253.tar.bz2 packages-463986858db228ccd96b7a5f46504df350f65253.zip |
Add to AUR
-rw-r--r-- | .SRCINFO | 14 | ||||
-rw-r--r-- | .gitignore | 4 | ||||
-rw-r--r-- | PKGBUILD | 38 |
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO new file mode 100644 index 0000000..b47ba0a --- /dev/null +++ b/.SRCINFO | |||
@@ -0,0 +1,14 @@ | |||
1 | pkgbase = dnsx | ||
2 | pkgdesc = Fast and multi-purpose DNS toolkit | ||
3 | pkgver = 1.0.0 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/projectdiscovery/dnsx | ||
6 | arch = x86_64 | ||
7 | license = MIT | ||
8 | makedepends = go | ||
9 | provides = dnsx | ||
10 | source = dnsx-1.0.0.tar.gz::https://github.com/projectdiscovery/dnsx/archive/v1.0.0.tar.gz | ||
11 | sha256sums = 112f81c2e5efc73103bebfb9e8f7db0c7e7e9a95ba432625a5469cfe0a104d06 | ||
12 | |||
13 | pkgname = dnsx | ||
14 | |||
diff --git a/.gitignore b/.gitignore new file mode 100644 index 0000000..05c6d4d --- /dev/null +++ b/.gitignore | |||
@@ -0,0 +1,4 @@ | |||
1 | * | ||
2 | !.gitignore | ||
3 | !.SRCINFO | ||
4 | !PKGBUILD | ||
diff --git a/PKGBUILD b/PKGBUILD new file mode 100644 index 0000000..4c4736a --- /dev/null +++ b/PKGBUILD | |||
@@ -0,0 +1,38 @@ | |||
1 | # Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz> | ||
2 | |||
3 | pkgname='dnsx' | ||
4 | pkgver=1.0.0 | ||
5 | pkgrel=1 | ||
6 | pkgdesc='Fast and multi-purpose DNS toolkit' | ||
7 | arch=('x86_64') | ||
8 | url='https://github.com/projectdiscovery/dnsx' | ||
9 | license=('MIT') | ||
10 | makedepends=('go') | ||
11 | provides=("${pkgname}") | ||
12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz") | ||
13 | sha256sums=('112f81c2e5efc73103bebfb9e8f7db0c7e7e9a95ba432625a5469cfe0a104d06') | ||
14 | |||
15 | prepare() { | ||
16 | export GOPATH="${srcdir}/gopath" | ||
17 | go clean -modcache | ||
18 | } | ||
19 | |||
20 | build() { | ||
21 | export CGO_CPPFLAGS="${CPPFLAGS}" | ||
22 | export CGO_CFLAGS="${CFLAGS}" | ||
23 | export CGO_CXXFLAGS="${CXXFLAGS}" | ||
24 | #export CGO_LDFLAGS="${LDFLAGS}" | ||
25 | export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw" | ||
26 | |||
27 | cd "${pkgname}-${pkgver}/cmd/${pkgname}" | ||
28 | go build -v -o "${pkgname}" . | ||
29 | } | ||
30 | |||
31 | package() { | ||
32 | cd "${pkgname}-${pkgver}" | ||
33 | install -Dvm755 "cmd/${pkgname}/${pkgname}" -t "${pkgdir}/usr/bin" | ||
34 | install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}" | ||
35 | install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" | ||
36 | } | ||
37 | |||
38 | # vim: ts=2 sw=2 et: | ||