summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBastien Traverse2018-02-05 00:58:41 +0100
committerBastien Traverse2018-02-05 01:01:40 +0100
commit2910ea7ec7fe94b1ad2cfd70adc510c80741ef97 (patch)
tree3721adf0208276a7bfad821d8215839771e7e7d9 /PKGBUILD
parent54f02a4e90824b8760d167451c133f83d5a5fce6 (diff)
downloadpackages-2910ea7ec7fe94b1ad2cfd70adc510c80741ef97.tar.gz
packages-2910ea7ec7fe94b1ad2cfd70adc510c80741ef97.tar.bz2
packages-2910ea7ec7fe94b1ad2cfd70adc510c80741ef97.zip
Switch to CI builds to get fresher versions & fix permissions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b73d45..0de2302 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,8 +14,8 @@
14pkgname=popcorntime-bin 14pkgname=popcorntime-bin
15_pkgname=popcorntime 15_pkgname=popcorntime
16pkgver=0.3.10 16pkgver=0.3.10
17pkgrel=1 17pkgrel=2
18pkgdesc="Stream movies and TV shows from torrents" 18pkgdesc="Stream movies and TV shows from torrents (continuous integration builds)"
19arch=('i686' 'x86_64') 19arch=('i686' 'x86_64')
20url="https://popcorntime.sh" 20url="https://popcorntime.sh"
21license=('GPL3') 21license=('GPL3')
@@ -24,11 +24,14 @@ provides=('popcorntime' 'popcorn-time-ce')
24conflicts=('popcorntime') 24conflicts=('popcorntime')
25options=('!strip') 25options=('!strip')
26source=("${_pkgname}.desktop") 26source=("${_pkgname}.desktop")
27source_i686=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz") 27## Official releases are lagging behind. Using CI builds instead
28source_x86_64=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz") 28#source_i686=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz")
29#source_x86_64=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz")
30source_i686=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/lastSuccessfulBuild/artifact/build/Popcorn-Time-${pkgver}_linux32.tar.xz")
31source_x86_64=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/lastSuccessfulBuild/artifact/build/Popcorn-Time-${pkgver}_linux64.tar.xz")
29sha256sums=('4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334') 32sha256sums=('4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334')
30sha256sums_i686=('c6497b067304918c3d19db2fecd36cc9efe1fff13765d461b24fd2cd8692ed42') 33sha256sums_i686=('6eb6a16cc40ed199c5e14b9a16f9dbb1bd45174b59a2a93271048ced21a2b618')
31sha256sums_x86_64=('b7f789c2e2f3b0f7e3408a437080404f8a2aa7ce4a41858cf891b02cda8c37a5') 34sha256sums_x86_64=('2509fe735b6517f9fec38f9c7f5652840a5ee5a7148e31f813b0946db4bca43e')
32 35
33package() { 36package() {
34 install -dm755 "${pkgdir}/usr/share/${_pkgname}" 37 install -dm755 "${pkgdir}/usr/share/${_pkgname}"
@@ -48,4 +51,8 @@ package() {
48 51
49 # Copy complete content of source archive to /usr/share/${_pkgname}/ 52 # Copy complete content of source archive to /usr/share/${_pkgname}/
50 cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}/" 53 cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}/"
54
55 # Fix permissions
56 find "${pkgdir}/usr/share/${_pkgname}/" -perm 600 -exec chmod 644 '{}' \;
57 find "${pkgdir}/usr/share/${_pkgname}/" -perm 700 -exec chmod 755 '{}' \;
51} 58}