diff options
author | Bastien Traverse | 2018-02-05 00:58:41 +0100 |
---|---|---|
committer | Bastien Traverse | 2018-02-05 01:01:40 +0100 |
commit | 2910ea7ec7fe94b1ad2cfd70adc510c80741ef97 (patch) | |
tree | 3721adf0208276a7bfad821d8215839771e7e7d9 /PKGBUILD | |
parent | 54f02a4e90824b8760d167451c133f83d5a5fce6 (diff) | |
download | packages-2910ea7ec7fe94b1ad2cfd70adc510c80741ef97.tar.gz packages-2910ea7ec7fe94b1ad2cfd70adc510c80741ef97.tar.bz2 packages-2910ea7ec7fe94b1ad2cfd70adc510c80741ef97.zip |
Switch to CI builds to get fresher versions & fix permissions
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 19 |
1 files changed, 13 insertions, 6 deletions
@@ -14,8 +14,8 @@ | |||
14 | pkgname=popcorntime-bin | 14 | pkgname=popcorntime-bin |
15 | _pkgname=popcorntime | 15 | _pkgname=popcorntime |
16 | pkgver=0.3.10 | 16 | pkgver=0.3.10 |
17 | pkgrel=1 | 17 | pkgrel=2 |
18 | pkgdesc="Stream movies and TV shows from torrents" | 18 | pkgdesc="Stream movies and TV shows from torrents (continuous integration builds)" |
19 | arch=('i686' 'x86_64') | 19 | arch=('i686' 'x86_64') |
20 | url="https://popcorntime.sh" | 20 | url="https://popcorntime.sh" |
21 | license=('GPL3') | 21 | license=('GPL3') |
@@ -24,11 +24,14 @@ provides=('popcorntime' 'popcorn-time-ce') | |||
24 | conflicts=('popcorntime') | 24 | conflicts=('popcorntime') |
25 | options=('!strip') | 25 | options=('!strip') |
26 | source=("${_pkgname}.desktop") | 26 | source=("${_pkgname}.desktop") |
27 | source_i686=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz") | 27 | ## Official releases are lagging behind. Using CI builds instead |
28 | source_x86_64=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz") | 28 | #source_i686=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz") |
29 | #source_x86_64=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz") | ||
30 | source_i686=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/lastSuccessfulBuild/artifact/build/Popcorn-Time-${pkgver}_linux32.tar.xz") | ||
31 | source_x86_64=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/lastSuccessfulBuild/artifact/build/Popcorn-Time-${pkgver}_linux64.tar.xz") | ||
29 | sha256sums=('4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334') | 32 | sha256sums=('4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334') |
30 | sha256sums_i686=('c6497b067304918c3d19db2fecd36cc9efe1fff13765d461b24fd2cd8692ed42') | 33 | sha256sums_i686=('6eb6a16cc40ed199c5e14b9a16f9dbb1bd45174b59a2a93271048ced21a2b618') |
31 | sha256sums_x86_64=('b7f789c2e2f3b0f7e3408a437080404f8a2aa7ce4a41858cf891b02cda8c37a5') | 34 | sha256sums_x86_64=('2509fe735b6517f9fec38f9c7f5652840a5ee5a7148e31f813b0946db4bca43e') |
32 | 35 | ||
33 | package() { | 36 | package() { |
34 | install -dm755 "${pkgdir}/usr/share/${_pkgname}" | 37 | install -dm755 "${pkgdir}/usr/share/${_pkgname}" |
@@ -48,4 +51,8 @@ package() { | |||
48 | 51 | ||
49 | # Copy complete content of source archive to /usr/share/${_pkgname}/ | 52 | # Copy complete content of source archive to /usr/share/${_pkgname}/ |
50 | cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}/" | 53 | cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}/" |
54 | |||
55 | # Fix permissions | ||
56 | find "${pkgdir}/usr/share/${_pkgname}/" -perm 600 -exec chmod 644 '{}' \; | ||
57 | find "${pkgdir}/usr/share/${_pkgname}/" -perm 700 -exec chmod 755 '{}' \; | ||
51 | } | 58 | } |