summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPieter Goetschalckx2016-11-08 13:03:57 +0100
committerPieter Goetschalckx2016-11-08 13:03:57 +0100
commit54f02a4e90824b8760d167451c133f83d5a5fce6 (patch)
tree8ce0025b9ef8018be71624333f3c67747d26dbbb /PKGBUILD
parent65f8d3ad3d184fcf348457a4043f78de86088c70 (diff)
downloadpackages-54f02a4e90824b8760d167451c133f83d5a5fce6.tar.gz
packages-54f02a4e90824b8760d167451c133f83d5a5fce6.tar.bz2
packages-54f02a4e90824b8760d167451c133f83d5a5fce6.zip
Version 0.3.10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 14 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7310e5..2b73d45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
1# Maintainer: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com> 1# Maintainer: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com>
2# Contributor: Bastien Traverse <firstname at lastname dot email>
2# Contributor: Ricardo Funke <ricardo [at] gmail [dot] com> 3# Contributor: Ricardo Funke <ricardo [at] gmail [dot] com>
3# Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu> 4# Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu>
4# Contributor: Iwan Timmer <irtimmer [at] gmail [dot] com> 5# Contributor: Iwan Timmer <irtimmer [at] gmail [dot] com>
@@ -12,8 +13,8 @@
12 13
13pkgname=popcorntime-bin 14pkgname=popcorntime-bin
14_pkgname=popcorntime 15_pkgname=popcorntime
15pkgver=0.3.9 16pkgver=0.3.10
16pkgrel=7 17pkgrel=1
17pkgdesc="Stream movies and TV shows from torrents" 18pkgdesc="Stream movies and TV shows from torrents"
18arch=('i686' 'x86_64') 19arch=('i686' 'x86_64')
19url="https://popcorntime.sh" 20url="https://popcorntime.sh"
@@ -23,29 +24,16 @@ provides=('popcorntime' 'popcorn-time-ce')
23conflicts=('popcorntime') 24conflicts=('popcorntime')
24options=('!strip') 25options=('!strip')
25source=("${_pkgname}.desktop") 26source=("${_pkgname}.desktop")
26source_i686=("https://get.popcorntime.sh/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz") 27source_i686=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz")
27source_x86_64=("https://get.popcorntime.sh/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz") 28source_x86_64=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz")
28sha256sums=('4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334') 29sha256sums=('4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334')
29sha256sums_i686=('0c8a84e853946c70b4986d8044ec869f995b8001b48cd5bd3ef0ed61e8848335') 30sha256sums_i686=('c6497b067304918c3d19db2fecd36cc9efe1fff13765d461b24fd2cd8692ed42')
30sha256sums_x86_64=('5655111b7f5883ce7a620a8fb0b9f7fb7563a46516697aac5ad2b28b8b5e49df') 31sha256sums_x86_64=('b7f789c2e2f3b0f7e3408a437080404f8a2aa7ce4a41858cf891b02cda8c37a5')
31
32[ "$CARCH" = "i686" ] && _platform=linux32
33[ "$CARCH" = "x86_64" ] && _platform=linux64
34 32
35package() { 33package() {
36 _bpath="${_platform}"
37
38 install -dm755 "${pkgdir}/usr/share/${_pkgname}" 34 install -dm755 "${pkgdir}/usr/share/${_pkgname}"
39 install -dm755 "${pkgdir}/usr/bin" 35 install -dm755 "${pkgdir}/usr/bin"
40 36
41 # Program
42 install -Dm755 "${_bpath}/Popcorn-Time" "${pkgdir}/usr/share/${_pkgname}/"
43 install -Dm644 "${_bpath}/"{icudtl.dat,libffmpegsumo.so,nw.pak,package.json} \
44 "${pkgdir}/usr/share/${_pkgname}/"
45
46 # Directories
47 cp -a "${_bpath}/"{locales,node_modules,src} "${pkgdir}/usr/share/${_pkgname}/"
48
49 # Link to program 37 # Link to program
50 ln -s "/usr/share/${_pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgname}" 38 ln -s "/usr/share/${_pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgname}"
51 39
@@ -53,6 +41,11 @@ package() {
53 install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop" 41 install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
54 42
55 # Icon 43 # Icon
56 install -Dm644 "${_bpath}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png" 44 install -Dm644 "${srcdir}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png"
57} 45
46 # Remove makepkg-created symlinks before copying content
47 rm *.tar.xz *.desktop
58 48
49 # Copy complete content of source archive to /usr/share/${_pkgname}/
50 cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}/"
51}