summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-06-28 17:45:07 +1200
committercaltlgin2020-06-28 17:45:07 +1200
commite641bedc28149a625e26e4912853fd043d0bbafc (patch)
tree1f1170f5e59dd5c077659f026dad924d08a96b56
downloadpackages-e641bedc28149a625e26e4912853fd043d0bbafc.tar.gz
packages-e641bedc28149a625e26e4912853fd043d0bbafc.tar.bz2
packages-e641bedc28149a625e26e4912853fd043d0bbafc.zip
Add to AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 0000000..396d3fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
1pkgbase = unsilence
2 pkgdesc = Console Interface and Library to remove silent parts of a media file
3 pkgver = 1.0.3
4 pkgrel = 1
5 url = https://github.com/lagmoellertim/unsilence
6 arch = any
7 license = MIT
8 makedepends = python-setuptools
9 depends = ffmpeg
10 depends = python-argparse
11 depends = python-rich
12 source = https://github.com/lagmoellertim/unsilence/archive/1.0.3.tar.gz
13 sha256sums = ac9ea5b5b5a8743133b4fd11fcc2b51418756e2d53530c71c0f663f44e24a56f
14
15pkgname = unsilence
16
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..7fb384a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
1# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
2
3pkgname=unsilence
4pkgver=1.0.3
5pkgrel=1
6pkgdesc='Console Interface and Library to remove silent parts of a media file'
7arch=('any')
8url='https://github.com/lagmoellertim/unsilence'
9license=('MIT')
10depends=('ffmpeg' 'python-argparse' 'python-rich')
11makedepends=('python-setuptools')
12source=("${url}/archive/${pkgver}.tar.gz")
13sha256sums=('ac9ea5b5b5a8743133b4fd11fcc2b51418756e2d53530c71c0f663f44e24a56f')
14
15build() {
16 cd "${pkgname}-${pkgver}"
17 python setup.py build
18}
19
20package() {
21 cd "${pkgname}-${pkgver}"
22 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
23 install -Dm644 'README.md' "${pkgdir}/usr/share/doc/${pkgname}/README.md"
24 install -Dm644 'LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
25}
26
27# vim: ts=2 sw=2 et: