diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 27 |
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD new file mode 100644 index 0000000..7fb384a --- /dev/null +++ b/PKGBUILD | |||
@@ -0,0 +1,27 @@ | |||
1 | # Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz> | ||
2 | |||
3 | pkgname=unsilence | ||
4 | pkgver=1.0.3 | ||
5 | pkgrel=1 | ||
6 | pkgdesc='Console Interface and Library to remove silent parts of a media file' | ||
7 | arch=('any') | ||
8 | url='https://github.com/lagmoellertim/unsilence' | ||
9 | license=('MIT') | ||
10 | depends=('ffmpeg' 'python-argparse' 'python-rich') | ||
11 | makedepends=('python-setuptools') | ||
12 | source=("${url}/archive/${pkgver}.tar.gz") | ||
13 | sha256sums=('ac9ea5b5b5a8743133b4fd11fcc2b51418756e2d53530c71c0f663f44e24a56f') | ||
14 | |||
15 | build() { | ||
16 | cd "${pkgname}-${pkgver}" | ||
17 | python setup.py build | ||
18 | } | ||
19 | |||
20 | package() { | ||
21 | cd "${pkgname}-${pkgver}" | ||
22 | python setup.py install --root="${pkgdir}" --optimize=1 --skip-build | ||
23 | install -Dm644 'README.md' "${pkgdir}/usr/share/doc/${pkgname}/README.md" | ||
24 | install -Dm644 'LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" | ||
25 | } | ||
26 | |||
27 | # vim: ts=2 sw=2 et: | ||