summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlesebas2015-06-23 23:37:14 +0200
committerYigit Sever2024-07-05 16:16:55 +0300
commit8b2a995ee41eae12349e80fe428e7a5f48d11e27 (patch)
tree7a79585ef80679f9d8ab0ff959c7985c80e0540f
parentc00f2ea9117881e8453ca45e8bafae00082264f4 (diff)
downloadpackages-8b2a995ee41eae12349e80fe428e7a5f48d11e27.tar.gz
packages-8b2a995ee41eae12349e80fe428e7a5f48d11e27.tar.bz2
packages-8b2a995ee41eae12349e80fe428e7a5f48d11e27.zip
move from AUR3 to AUR4
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD68
-rw-r--r--serviio-console.sh8
-rw-r--r--serviio.desktop12
-rw-r--r--serviio.install15
-rw-r--r--serviio.pngbin0 -> 1779 bytes
-rw-r--r--serviio.service9
-rw-r--r--serviio.sh18
8 files changed, 158 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 0000000..9f68100
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
1# Generated by makepkg 4.2.1
2# Tue Apr 14 20:06:25 UTC 2015
3pkgbase = serviio
4 pkgdesc = Free DLNA media server
5 pkgver = 1.5.2
6 pkgrel = 2
7 url = http://www.serviio.org/
8 arch = any
9 license = custom
10 depends = java-runtime-headless=8
11 depends = ffmpeg
12 source = http://download.serviio.org/releases/serviio-1.5.2-linux.tar.gz
13 source = serviio.sh
14 source = serviio-console.sh
15 source = serviio.service
16 source = serviio.desktop
17 source = serviio.png
18 source = serviio.install
19 md5sums = 70cfa7d9f54b1c921194b6c0d6530ed6
20 md5sums = 227a75de2dea1db93c1fba3d004e01ad
21 md5sums = 7f38b2f294ce990958dcc63b583807b4
22 md5sums = e958d9812448f97fe325dfffe8b44620
23 md5sums = fbfcac4ad5dffd909e51ea1a7a6335aa
24 md5sums = d41e3e757e412dfcd3036d9e19b81450
25 md5sums = 0b89d6c683305ef4473fab4c6688c7ab
26
27pkgname = serviio
28
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..57163d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
1pkgname=serviio
2pkgver=1.5.2
3pkgrel=2
4pkgdesc="Free DLNA media server"
5arch=('any')
6url="http://www.serviio.org/"
7license=('custom')
8depends=('java-runtime-headless=8' 'ffmpeg')
9source=(http://download.serviio.org/releases/serviio-${pkgver}-linux.tar.gz
10 $pkgname.sh
11 $pkgname-console.sh
12 $pkgname.service
13 $pkgname.desktop
14 $pkgname.png
15 $pkgname.install)
16md5sums=('70cfa7d9f54b1c921194b6c0d6530ed6'
17 '227a75de2dea1db93c1fba3d004e01ad'
18 '7f38b2f294ce990958dcc63b583807b4'
19 'e958d9812448f97fe325dfffe8b44620'
20 'fbfcac4ad5dffd909e51ea1a7a6335aa'
21 'd41e3e757e412dfcd3036d9e19b81450'
22 '0b89d6c683305ef4473fab4c6688c7ab')
23
24package() {
25 cd "$pkgname-$pkgver"
26
27 # define variable for Serviio home directory
28 SERVIIO_HOME=$pkgdir/usr/share/java/$pkgname
29
30 # create the folders needed in the main directory
31 install -dm755 ${SERVIIO_HOME}/{config,lib,library,plugins}
32
33 # place the serviio scripts in the /usr/bin folder
34 install -Dm755 ${srcdir}/$pkgname.sh $pkgdir/usr/bin/$pkgname
35 install -Dm755 ${srcdir}/$pkgname-console.sh $pkgdir/usr/bin/$pkgname-console
36
37 # copy xml config files to the config folder
38 install -m644 config/*.xml ${SERVIIO_HOME}/config
39
40 # copy all jar files to the lib folder
41 install -m644 lib/*.jar ${SERVIIO_HOME}/lib
42
43 # copy derby.properties to library folder
44 install -m644 library/derby.properties ${SERVIIO_HOME}/library
45
46 # copy plugins-readme.txt to plugins folder
47 install -m644 plugins/plugins-readme.txt ${SERVIIO_HOME}/plugins
48
49 # create the log folder in /var/log
50 install -dm755 $pkgdir/var/log/$pkgname
51
52 # create a symlink that puts all log files in /var/log
53 ln -s /var/log/$pkgname ${SERVIIO_HOME}/log
54
55 # supply the license file
56 install -Dm644 LICENCE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
57
58 # install systemd-service
59 install -Dm644 "${srcdir}/$pkgname.service" "$pkgdir/usr/lib/systemd/system/$pkgname.service"
60
61 #install the .desktop file
62 install -Dm644 "${srcdir}/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
63
64 #install the icon file
65 install -Dm644 "${srcdir}/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/48x48/apps/$pkgname.png"
66
67
68} \ No newline at end of file
diff --git a/serviio-console.sh b/serviio-console.sh
new file mode 100644
index 0000000..976d59b
--- /dev/null
+++ b/serviio-console.sh
@@ -0,0 +1,8 @@
1#!/bin/sh
2
3 export PATH=/usr/lib/jvm/java-8-openjdk/jre/bin/:$PATH
4 SERVIIO_CONSOLE_HOME="/usr/share/java/serviio"
5 SERVIIO_CLASS_PATH="$SERVIIO_CONSOLE_HOME/lib/*:$SERVIIO_CONSOLE_HOME/config"
6 JAVA_OPTS="-Dserviio.home=$SERVIIO_CONSOLE_HOME -Djava.net.preferIPv4Stack=true"
7
8 java -Xmx512M $JAVA_OPTS -classpath $SERVIIO_CLASS_PATH org.serviio.console.ServiioConsole "$@"
diff --git a/serviio.desktop b/serviio.desktop
new file mode 100644
index 0000000..1a62ec6
--- /dev/null
+++ b/serviio.desktop
@@ -0,0 +1,12 @@
1[Desktop Entry]
2Version=1.0
3Type=Application
4Name=Serviio
5Comment[fr]=Console d'administration du serveur DLNA
6Comment[en]=Administration console of DLNA server
7Exec= serviio-console
8Categories=AudioVideo
9Icon=serviio
10Path=
11Terminal=false
12StartupNotify=false
diff --git a/serviio.install b/serviio.install
new file mode 100644
index 0000000..043ea27
--- /dev/null
+++ b/serviio.install
@@ -0,0 +1,15 @@
1
2post_install() {
3 update-desktop-database -q
4 gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
5}
6
7
8post_upgrade() {
9 gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
10}
11
12post_remove() {
13 update-desktop-database -q
14 gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
15} \ No newline at end of file
diff --git a/serviio.png b/serviio.png
new file mode 100644
index 0000000..f2eefad
--- /dev/null
+++ b/serviio.png
Binary files differ
diff --git a/serviio.service b/serviio.service
new file mode 100644
index 0000000..54e2855
--- /dev/null
+++ b/serviio.service
@@ -0,0 +1,9 @@
1[Unit]
2Description=Serviio
3After=network.target
4
5[Service]
6ExecStart=/usr/bin/serviio
7
8[Install]
9WantedBy=multi-user.target
diff --git a/serviio.sh b/serviio.sh
new file mode 100644
index 0000000..451a645
--- /dev/null
+++ b/serviio.sh
@@ -0,0 +1,18 @@
1#!/bin/sh
2
3if [ $UID -eq 0 ]
4then
5 if [[ -f /etc/profile.d/jdk.sh ]]; then
6 . /etc/profile.d/jdk.sh
7 elif [[ -f /etc/profile.d/jre.sh ]]; then
8 . /etc/profile.d/jre.sh
9 fi
10 export PATH=/usr/lib/jvm/java-8-openjdk/jre/bin/:$PATH
11 SERVIIO_HOME="/usr/share/java/serviio"
12 SERVIIO_CLASS_PATH="$SERVIIO_HOME/lib/*:$SERVIIO_HOME/config"
13 JAVA_OPTS="-Djava.net.preferIPv4Stack=true -Djava.awt.headless=true -Dderby.system.home=$SERVIIO_HOME/library -Dserviio.home=$SERVIIO_HOME -Dffmpeg.location=ffmpeg"
14
15 java -Xmx384M $JAVA_OPTS -classpath $SERVIIO_CLASS_PATH org.serviio.MediaServer "$@"
16else
17 echo "Must be run as root."
18fi