diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 68 |
1 files changed, 68 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD new file mode 100644 index 0000000..57163d1 --- /dev/null +++ b/PKGBUILD | |||
@@ -0,0 +1,68 @@ | |||
1 | pkgname=serviio | ||
2 | pkgver=1.5.2 | ||
3 | pkgrel=2 | ||
4 | pkgdesc="Free DLNA media server" | ||
5 | arch=('any') | ||
6 | url="http://www.serviio.org/" | ||
7 | license=('custom') | ||
8 | depends=('java-runtime-headless=8' 'ffmpeg') | ||
9 | source=(http://download.serviio.org/releases/serviio-${pkgver}-linux.tar.gz | ||
10 | $pkgname.sh | ||
11 | $pkgname-console.sh | ||
12 | $pkgname.service | ||
13 | $pkgname.desktop | ||
14 | $pkgname.png | ||
15 | $pkgname.install) | ||
16 | md5sums=('70cfa7d9f54b1c921194b6c0d6530ed6' | ||
17 | '227a75de2dea1db93c1fba3d004e01ad' | ||
18 | '7f38b2f294ce990958dcc63b583807b4' | ||
19 | 'e958d9812448f97fe325dfffe8b44620' | ||
20 | 'fbfcac4ad5dffd909e51ea1a7a6335aa' | ||
21 | 'd41e3e757e412dfcd3036d9e19b81450' | ||
22 | '0b89d6c683305ef4473fab4c6688c7ab') | ||
23 | |||
24 | package() { | ||
25 | cd "$pkgname-$pkgver" | ||
26 | |||
27 | # define variable for Serviio home directory | ||
28 | SERVIIO_HOME=$pkgdir/usr/share/java/$pkgname | ||
29 | |||
30 | # create the folders needed in the main directory | ||
31 | install -dm755 ${SERVIIO_HOME}/{config,lib,library,plugins} | ||
32 | |||
33 | # place the serviio scripts in the /usr/bin folder | ||
34 | install -Dm755 ${srcdir}/$pkgname.sh $pkgdir/usr/bin/$pkgname | ||
35 | install -Dm755 ${srcdir}/$pkgname-console.sh $pkgdir/usr/bin/$pkgname-console | ||
36 | |||
37 | # copy xml config files to the config folder | ||
38 | install -m644 config/*.xml ${SERVIIO_HOME}/config | ||
39 | |||
40 | # copy all jar files to the lib folder | ||
41 | install -m644 lib/*.jar ${SERVIIO_HOME}/lib | ||
42 | |||
43 | # copy derby.properties to library folder | ||
44 | install -m644 library/derby.properties ${SERVIIO_HOME}/library | ||
45 | |||
46 | # copy plugins-readme.txt to plugins folder | ||
47 | install -m644 plugins/plugins-readme.txt ${SERVIIO_HOME}/plugins | ||
48 | |||
49 | # create the log folder in /var/log | ||
50 | install -dm755 $pkgdir/var/log/$pkgname | ||
51 | |||
52 | # create a symlink that puts all log files in /var/log | ||
53 | ln -s /var/log/$pkgname ${SERVIIO_HOME}/log | ||
54 | |||
55 | # supply the license file | ||
56 | install -Dm644 LICENCE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE | ||
57 | |||
58 | # install systemd-service | ||
59 | install -Dm644 "${srcdir}/$pkgname.service" "$pkgdir/usr/lib/systemd/system/$pkgname.service" | ||
60 | |||
61 | #install the .desktop file | ||
62 | install -Dm644 "${srcdir}/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop" | ||
63 | |||
64 | #install the icon file | ||
65 | install -Dm644 "${srcdir}/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/48x48/apps/$pkgname.png" | ||
66 | |||
67 | |||
68 | } \ No newline at end of file | ||