summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2023-01-16 19:46:07 +1300
committerGeorge Rawlinson2023-01-16 19:46:07 +1300
commit7b851a3adb79143f9de52ad4bac909e23d04f431 (patch)
treee178a6d87765ee25e8f006a972e8250f85e9955f
parent5e7585237556903f8d1148877be29b1972088e3b (diff)
downloadpackages-7b851a3adb79143f9de52ad4bac909e23d04f431.tar.gz
packages-7b851a3adb79143f9de52ad4bac909e23d04f431.tar.bz2
packages-7b851a3adb79143f9de52ad4bac909e23d04f431.zip
upgpkg: xq 1.1.2-1; enable debug package
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e196678..6f15870 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
1pkgbase = xq 1pkgbase = xq
2 pkgdesc = Command-line XML and HTML beautifier and content extractor 2 pkgdesc = Command-line XML and HTML beautifier and content extractor
3 pkgver = 1.1.1 3 pkgver = 1.1.2
4 pkgrel = 1 4 pkgrel = 1
5 url = https://github.com/sibprogrammer/xq 5 url = https://github.com/sibprogrammer/xq
6 arch = x86_64 6 arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = xq
10 depends = glibc 10 depends = glibc
11 conflicts = yq 11 conflicts = yq
12 options = !lto 12 options = !lto
13 source = xq::git+https://github.com/sibprogrammer/xq#commit=f0c2fb2fb0dcc90e9422a219ffdf437113777388 13 source = xq::git+https://github.com/sibprogrammer/xq#commit=7c585a2e6ccd7e6e3adc63e4524023389135c938
14 source = manpage-template.patch 14 source = manpage-template.patch
15 b2sums = SKIP 15 b2sums = SKIP
16 b2sums = f2448e22798e018d6962016dc800ff96ae9c23b776742348a7036d613efa8c37e5c8c7a539804f2daebc4c152495cc1cbbcb2635fcf223e958596333cab1b843 16 b2sums = f2448e22798e018d6962016dc800ff96ae9c23b776742348a7036d613efa8c37e5c8c7a539804f2daebc4c152495cc1cbbcb2635fcf223e958596333cab1b843
diff --git a/PKGBUILD b/PKGBUILD
index 8c659af..69eb92e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
1# Maintainer: George Rawlinson <grawlinson@archlinux.org> 1# Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 2
3pkgname=xq 3pkgname=xq
4pkgver=1.1.1 4pkgver=1.1.2
5pkgrel=1 5pkgrel=1
6pkgdesc='Command-line XML and HTML beautifier and content extractor' 6pkgdesc='Command-line XML and HTML beautifier and content extractor'
7arch=('x86_64') 7arch=('x86_64')
@@ -11,7 +11,7 @@ depends=('glibc')
11makedepends=('git' 'go') 11makedepends=('git' 'go')
12conflicts=('yq') 12conflicts=('yq')
13options=('!lto') 13options=('!lto')
14_commit='f0c2fb2fb0dcc90e9422a219ffdf437113777388' 14_commit='7c585a2e6ccd7e6e3adc63e4524023389135c938'
15source=( 15source=(
16 "$pkgname::git+$url#commit=$_commit" 16 "$pkgname::git+$url#commit=$_commit"
17 'manpage-template.patch' 17 'manpage-template.patch'
@@ -45,16 +45,18 @@ build() {
45 export CGO_CPPFLAGS="${CPPFLAGS}" 45 export CGO_CPPFLAGS="${CPPFLAGS}"
46 export CGO_CFLAGS="${CFLAGS}" 46 export CGO_CFLAGS="${CFLAGS}"
47 export CGO_CXXFLAGS="${CXXFLAGS}" 47 export CGO_CXXFLAGS="${CXXFLAGS}"
48 export GOPATH="${srcdir}"
48 49
49 # commit date for binary & man page 50 # commit date for binary & man page
50 local _commit_date=$(git show --no-patch --format=%cd --date=format:%Y-%m-%d) 51 local _commit_date=$(git show --no-patch --format=%cd --date=format:%Y-%m-%d)
51 52
52 go build -v \ 53 go build -v \
53 -trimpath \
54 -buildmode=pie \ 54 -buildmode=pie \
55 -mod=readonly \ 55 -mod=readonly \
56 -modcacherw \ 56 -modcacherw \
57 -ldflags "-linkmode external -extldflags ${LDFLAGS} \ 57 -ldflags "-compressdwarf=false \
58 -linkmode external \
59 -extldflags ${LDFLAGS} \
58 -X main.commit=$_commit \ 60 -X main.commit=$_commit \
59 -X main.date=$_commit_date \ 61 -X main.date=$_commit_date \
60 -X main.version=$pkgver" \ 62 -X main.version=$pkgver" \