diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 10 |
1 files changed, 6 insertions, 4 deletions
@@ -1,7 +1,7 @@ | |||
1 | # Maintainer: George Rawlinson <grawlinson@archlinux.org> | 1 | # Maintainer: George Rawlinson <grawlinson@archlinux.org> |
2 | 2 | ||
3 | pkgname=xq | 3 | pkgname=xq |
4 | pkgver=1.1.1 | 4 | pkgver=1.1.2 |
5 | pkgrel=1 | 5 | pkgrel=1 |
6 | pkgdesc='Command-line XML and HTML beautifier and content extractor' | 6 | pkgdesc='Command-line XML and HTML beautifier and content extractor' |
7 | arch=('x86_64') | 7 | arch=('x86_64') |
@@ -11,7 +11,7 @@ depends=('glibc') | |||
11 | makedepends=('git' 'go') | 11 | makedepends=('git' 'go') |
12 | conflicts=('yq') | 12 | conflicts=('yq') |
13 | options=('!lto') | 13 | options=('!lto') |
14 | _commit='f0c2fb2fb0dcc90e9422a219ffdf437113777388' | 14 | _commit='7c585a2e6ccd7e6e3adc63e4524023389135c938' |
15 | source=( | 15 | source=( |
16 | "$pkgname::git+$url#commit=$_commit" | 16 | "$pkgname::git+$url#commit=$_commit" |
17 | 'manpage-template.patch' | 17 | 'manpage-template.patch' |
@@ -45,16 +45,18 @@ build() { | |||
45 | export CGO_CPPFLAGS="${CPPFLAGS}" | 45 | export CGO_CPPFLAGS="${CPPFLAGS}" |
46 | export CGO_CFLAGS="${CFLAGS}" | 46 | export CGO_CFLAGS="${CFLAGS}" |
47 | export CGO_CXXFLAGS="${CXXFLAGS}" | 47 | export CGO_CXXFLAGS="${CXXFLAGS}" |
48 | export GOPATH="${srcdir}" | ||
48 | 49 | ||
49 | # commit date for binary & man page | 50 | # commit date for binary & man page |
50 | local _commit_date=$(git show --no-patch --format=%cd --date=format:%Y-%m-%d) | 51 | local _commit_date=$(git show --no-patch --format=%cd --date=format:%Y-%m-%d) |
51 | 52 | ||
52 | go build -v \ | 53 | go build -v \ |
53 | -trimpath \ | ||
54 | -buildmode=pie \ | 54 | -buildmode=pie \ |
55 | -mod=readonly \ | 55 | -mod=readonly \ |
56 | -modcacherw \ | 56 | -modcacherw \ |
57 | -ldflags "-linkmode external -extldflags ${LDFLAGS} \ | 57 | -ldflags "-compressdwarf=false \ |
58 | -linkmode external \ | ||
59 | -extldflags ${LDFLAGS} \ | ||
58 | -X main.commit=$_commit \ | 60 | -X main.commit=$_commit \ |
59 | -X main.date=$_commit_date \ | 61 | -X main.date=$_commit_date \ |
60 | -X main.version=$pkgver" \ | 62 | -X main.version=$pkgver" \ |