summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c659af..69eb92e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
1# Maintainer: George Rawlinson <grawlinson@archlinux.org> 1# Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 2
3pkgname=xq 3pkgname=xq
4pkgver=1.1.1 4pkgver=1.1.2
5pkgrel=1 5pkgrel=1
6pkgdesc='Command-line XML and HTML beautifier and content extractor' 6pkgdesc='Command-line XML and HTML beautifier and content extractor'
7arch=('x86_64') 7arch=('x86_64')
@@ -11,7 +11,7 @@ depends=('glibc')
11makedepends=('git' 'go') 11makedepends=('git' 'go')
12conflicts=('yq') 12conflicts=('yq')
13options=('!lto') 13options=('!lto')
14_commit='f0c2fb2fb0dcc90e9422a219ffdf437113777388' 14_commit='7c585a2e6ccd7e6e3adc63e4524023389135c938'
15source=( 15source=(
16 "$pkgname::git+$url#commit=$_commit" 16 "$pkgname::git+$url#commit=$_commit"
17 'manpage-template.patch' 17 'manpage-template.patch'
@@ -45,16 +45,18 @@ build() {
45 export CGO_CPPFLAGS="${CPPFLAGS}" 45 export CGO_CPPFLAGS="${CPPFLAGS}"
46 export CGO_CFLAGS="${CFLAGS}" 46 export CGO_CFLAGS="${CFLAGS}"
47 export CGO_CXXFLAGS="${CXXFLAGS}" 47 export CGO_CXXFLAGS="${CXXFLAGS}"
48 export GOPATH="${srcdir}"
48 49
49 # commit date for binary & man page 50 # commit date for binary & man page
50 local _commit_date=$(git show --no-patch --format=%cd --date=format:%Y-%m-%d) 51 local _commit_date=$(git show --no-patch --format=%cd --date=format:%Y-%m-%d)
51 52
52 go build -v \ 53 go build -v \
53 -trimpath \
54 -buildmode=pie \ 54 -buildmode=pie \
55 -mod=readonly \ 55 -mod=readonly \
56 -modcacherw \ 56 -modcacherw \
57 -ldflags "-linkmode external -extldflags ${LDFLAGS} \ 57 -ldflags "-compressdwarf=false \
58 -linkmode external \
59 -extldflags ${LDFLAGS} \
58 -X main.commit=$_commit \ 60 -X main.commit=$_commit \
59 -X main.date=$_commit_date \ 61 -X main.date=$_commit_date \
60 -X main.version=$pkgver" \ 62 -X main.version=$pkgver" \