summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2022-12-16 00:17:24 +0300
committerYigit Sever2022-12-16 00:17:24 +0300
commit3fa329d1a734500f4eb22806d62a7317041bf2ca (patch)
treedd9309c21b5eac3a29d5fce28a364dfd3a93390b
parent6c4dea15b424c60ef4b4afa2860eac46757f6c48 (diff)
downloadpackages-3fa329d1a734500f4eb22806d62a7317041bf2ca.tar.gz
packages-3fa329d1a734500f4eb22806d62a7317041bf2ca.tar.bz2
packages-3fa329d1a734500f4eb22806d62a7317041bf2ca.zip
Deleted package: unsilence
-rw-r--r--unsilence/.SRCINFO16
-rw-r--r--unsilence/.gitignore4
-rw-r--r--unsilence/PKGBUILD28
3 files changed, 0 insertions, 48 deletions
diff --git a/unsilence/.SRCINFO b/unsilence/.SRCINFO
deleted file mode 100644
index 958ad04..0000000
--- a/unsilence/.SRCINFO
+++ /dev/null
@@ -1,16 +0,0 @@
1pkgbase = unsilence
2 pkgdesc = Console Interface and Library to remove silent parts of a media file
3 pkgver = 1.0.8
4 pkgrel = 1
5 url = https://github.com/lagmoellertim/unsilence
6 arch = any
7 license = MIT
8 makedepends = python-setuptools
9 depends = ffmpeg
10 depends = python
11 depends = python-argparse
12 depends = python-rich
13 source = unsilence-1.0.8.tar.gz::https://github.com/lagmoellertim/unsilence/archive/1.0.8.tar.gz
14 sha256sums = bd377d279ae155d02cc29cb6fbe836021c2ca2d1bc2766675c0beeb2f50c9e43
15
16pkgname = unsilence
diff --git a/unsilence/.gitignore b/unsilence/.gitignore
deleted file mode 100644
index 05c6d4d..0000000
--- a/unsilence/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
1*
2!.gitignore
3!.SRCINFO
4!PKGBUILD
diff --git a/unsilence/PKGBUILD b/unsilence/PKGBUILD
deleted file mode 100644
index ca792d2..0000000
--- a/unsilence/PKGBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3
4pkgname=unsilence
5pkgver=1.0.8
6pkgrel=1
7pkgdesc='Console Interface and Library to remove silent parts of a media file'
8arch=('any')
9url='https://github.com/lagmoellertim/unsilence'
10license=('MIT')
11depends=('ffmpeg' 'python' 'python-argparse' 'python-rich')
12makedepends=('python-setuptools')
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
14sha256sums=('bd377d279ae155d02cc29cb6fbe836021c2ca2d1bc2766675c0beeb2f50c9e43')
15
16build() {
17 cd "${pkgname}-${pkgver}"
18 sed -i 's/9.10.0/10.11.0/' requirements.txt
19 python setup.py build
20}
21
22package() {
23 cd "${pkgname}-${pkgver}"
24 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
25 install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
26 install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
27 rm -r "${pkgdir}/usr/lib/python"*'/site-packages/examples'
28}