diff options
Diffstat (limited to 'unsilence/PKGBUILD')
-rw-r--r-- | unsilence/PKGBUILD | 28 |
1 files changed, 0 insertions, 28 deletions
diff --git a/unsilence/PKGBUILD b/unsilence/PKGBUILD deleted file mode 100644 index ca792d2..0000000 --- a/unsilence/PKGBUILD +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz> | ||
3 | |||
4 | pkgname=unsilence | ||
5 | pkgver=1.0.8 | ||
6 | pkgrel=1 | ||
7 | pkgdesc='Console Interface and Library to remove silent parts of a media file' | ||
8 | arch=('any') | ||
9 | url='https://github.com/lagmoellertim/unsilence' | ||
10 | license=('MIT') | ||
11 | depends=('ffmpeg' 'python' 'python-argparse' 'python-rich') | ||
12 | makedepends=('python-setuptools') | ||
13 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") | ||
14 | sha256sums=('bd377d279ae155d02cc29cb6fbe836021c2ca2d1bc2766675c0beeb2f50c9e43') | ||
15 | |||
16 | build() { | ||
17 | cd "${pkgname}-${pkgver}" | ||
18 | sed -i 's/9.10.0/10.11.0/' requirements.txt | ||
19 | python setup.py build | ||
20 | } | ||
21 | |||
22 | package() { | ||
23 | cd "${pkgname}-${pkgver}" | ||
24 | python setup.py install --root="${pkgdir}" --optimize=1 --skip-build | ||
25 | install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md' | ||
26 | install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE' | ||
27 | rm -r "${pkgdir}/usr/lib/python"*'/site-packages/examples' | ||
28 | } | ||