aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorYigit Sever2021-04-14 03:27:27 +0300
committerYigit Sever2021-04-14 19:11:49 +0300
commite466f25ecfa356137523ee597b9fc6ab0da5df22 (patch)
tree06946f8811f90cf89ddc0afe685f15e9b3cf6cda /Cargo.toml
parentdb5a025bae30bfb6044e87eb196cc6bb63eb68d3 (diff)
downloadgradecoin-e466f25ecfa356137523ee597b9fc6ab0da5df22.tar.gz
gradecoin-e466f25ecfa356137523ee597b9fc6ab0da5df22.tar.bz2
gradecoin-e466f25ecfa356137523ee597b9fc6ab0da5df22.zip
[WIP] Initial implementation of user auth
There is a dance involved and everything Write down specs for RSA and AES, padding scheme, ugh.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6701daf..3b6e71e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -20,6 +20,9 @@ blake2 = "0.9.1"
20hex-literal = "0.3.1" 20hex-literal = "0.3.1"
21jsonwebtoken = "7.2.0" 21jsonwebtoken = "7.2.0"
22md-5 = "0.9.1" 22md-5 = "0.9.1"
23rsa = "0.4.0"
24base64 = "0.13.0"
25sha2 = "0.9.3"
23 26
24[dev-dependencies] 27[dev-dependencies]
25serde_test = "1.0.117" 28serde_test = "1.0.117"