aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorYigit Sever2021-04-12 05:32:53 +0300
committerYigit Sever2021-04-12 05:32:53 +0300
commite0fb91039f34204b2a5c588a95cb3f1789ad2fa7 (patch)
tree9c38670c348f04c57185639c541a1a93b8cfde2a /Cargo.toml
parent62aa261e1fd531afd1e5fa7244471d051a78db38 (diff)
downloadgradecoin-e0fb91039f34204b2a5c588a95cb3f1789ad2fa7.tar.gz
gradecoin-e0fb91039f34204b2a5c588a95cb3f1789ad2fa7.tar.bz2
gradecoin-e0fb91039f34204b2a5c588a95cb3f1789ad2fa7.zip
Implement proof-of-work
Using blacke2s: https://docs.rs/blake2/0.9.1/blake2/ Using this guy's hash checker https://gist.github.com/gkbrk/2e4835e3a17b3fb6e1e7 blacke2s with 5 bits 0 can mine a block between 20 seconds to 359 during my tests, hope it'll be fun
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2ae2b25..7e12c2d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,6 +16,8 @@ pretty_env_logger = "0.3.1"
16parking_lot = "0.10.0" 16parking_lot = "0.10.0"
17serde_json = "1.0.59" 17serde_json = "1.0.59"
18lazy_static = "1.4.0" 18lazy_static = "1.4.0"
19blake2 = "0.9.1"
20hex-literal = "0.3.1"
19 21
20[dev-dependencies] 22[dev-dependencies]
21serde_test = "1.0.117" 23serde_test = "1.0.117"