summaryrefslogtreecommitdiffstats
path: root/wapiti/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'wapiti/PKGBUILD')
-rw-r--r--wapiti/PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/wapiti/PKGBUILD b/wapiti/PKGBUILD
new file mode 100644
index 0000000..5020cab
--- /dev/null
+++ b/wapiti/PKGBUILD
@@ -0,0 +1,44 @@
1# Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
2# Contributor : mickael9 <mickael9 at gmail dot com>
3
4
5pkgname=wapiti
6
7pkgver=3.1.2
8_name="$pkgname${pkgver:0:1}"
9pkgrel=1
10
11pkgdesc='Comprehensive web app vulnerability scanner written in Python'
12arch=('any')
13url="https://$pkgname-scanner.github.io"
14license=('GPL')
15
16makedepends=('python-setuptools')
17depends=('python' 'python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-yaswfp'
18 'python-browser-cookie3' 'python-mako' 'python-python-socks' 'python-tld' 'python-httpx'
19 'python-aiocache' 'python-sqlalchemy')
20optdepends=('python-requests-kerberos: Kerberos authentication'
21 'python-requests-ntlm: NTLM authentication')
22
23options=('zipman')
24
25changelog=ChangeLog
26source=("https://github.com/$pkgname-scanner/$pkgname/releases/download/$pkgver/$_name-$pkgver.tar.gz")
27#source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$_name-$pkgver.tar.gz")
28sha256sums=('d10c51577792f949c9afa143043c9a25e6e86542cb48489d944ace45612aaea9')
29
30
31prepare() { rm -rf "$_name-$pkgver/tests"; }
32
33build() {
34 cd "$_name-$pkgver"
35 python setup.py build
36}
37
38package() {
39 cd "$_name-$pkgver"
40 PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
41}
42
43
44# vim: ts=2 sw=2 et ft=PKGBUILD: