diff options
Diffstat (limited to 'unsilence')
-rw-r--r-- | unsilence/.SRCINFO | 3 | ||||
-rw-r--r-- | unsilence/PKGBUILD | 6 |
2 files changed, 4 insertions, 5 deletions
diff --git a/unsilence/.SRCINFO b/unsilence/.SRCINFO index 63c4aa7..e8f8045 100644 --- a/unsilence/.SRCINFO +++ b/unsilence/.SRCINFO | |||
@@ -1,14 +1,13 @@ | |||
1 | pkgbase = unsilence | 1 | pkgbase = unsilence |
2 | pkgdesc = Console Interface and Library to remove silent parts of a media file | 2 | pkgdesc = Console Interface and Library to remove silent parts of a media file |
3 | pkgver = 1.0.9 | 3 | pkgver = 1.0.9 |
4 | pkgrel = 1 | 4 | pkgrel = 2 |
5 | url = https://github.com/lagmoellertim/unsilence | 5 | url = https://github.com/lagmoellertim/unsilence |
6 | arch = any | 6 | arch = any |
7 | license = MIT | 7 | license = MIT |
8 | makedepends = python-setuptools | 8 | makedepends = python-setuptools |
9 | depends = ffmpeg | 9 | depends = ffmpeg |
10 | depends = python | 10 | depends = python |
11 | depends = python-argparse | ||
12 | depends = python-rich | 11 | depends = python-rich |
13 | source = unsilence-1.0.9.tar.gz::https://github.com/lagmoellertim/unsilence/archive/1.0.9.tar.gz | 12 | source = unsilence-1.0.9.tar.gz::https://github.com/lagmoellertim/unsilence/archive/1.0.9.tar.gz |
14 | sha256sums = 5ce2efff1cbbdb42b66bf3eb28f326a51bed2a03ddf57de02cd6a634ca15cc5b | 13 | sha256sums = 5ce2efff1cbbdb42b66bf3eb28f326a51bed2a03ddf57de02cd6a634ca15cc5b |
diff --git a/unsilence/PKGBUILD b/unsilence/PKGBUILD index 72c1c80..973c29d 100644 --- a/unsilence/PKGBUILD +++ b/unsilence/PKGBUILD | |||
@@ -3,19 +3,19 @@ | |||
3 | 3 | ||
4 | pkgname=unsilence | 4 | pkgname=unsilence |
5 | pkgver=1.0.9 | 5 | pkgver=1.0.9 |
6 | pkgrel=1 | 6 | pkgrel=2 |
7 | pkgdesc='Console Interface and Library to remove silent parts of a media file' | 7 | pkgdesc='Console Interface and Library to remove silent parts of a media file' |
8 | arch=('any') | 8 | arch=('any') |
9 | url='https://github.com/lagmoellertim/unsilence' | 9 | url='https://github.com/lagmoellertim/unsilence' |
10 | license=('MIT') | 10 | license=('MIT') |
11 | depends=('ffmpeg' 'python' 'python-argparse' 'python-rich') | 11 | depends=('ffmpeg' 'python' 'python-rich') |
12 | makedepends=('python-setuptools') | 12 | makedepends=('python-setuptools') |
13 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") | 13 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") |
14 | sha256sums=('5ce2efff1cbbdb42b66bf3eb28f326a51bed2a03ddf57de02cd6a634ca15cc5b') | 14 | sha256sums=('5ce2efff1cbbdb42b66bf3eb28f326a51bed2a03ddf57de02cd6a634ca15cc5b') |
15 | 15 | ||
16 | build() { | 16 | build() { |
17 | cd "${pkgname}-${pkgver}" | 17 | cd "${pkgname}-${pkgver}" |
18 | sed -i 's/10.10.0/12.6.0/' requirements.txt | 18 | sed -i 's/rich~=10.10.0/rich>=10.10.0/' requirements.txt |
19 | python setup.py build | 19 | python setup.py build |
20 | } | 20 | } |
21 | 21 | ||