summaryrefslogtreecommitdiffstats
path: root/ryokucha/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'ryokucha/PKGBUILD')
-rw-r--r--ryokucha/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/ryokucha/PKGBUILD b/ryokucha/PKGBUILD
new file mode 100644
index 0000000..9d4ae5a
--- /dev/null
+++ b/ryokucha/PKGBUILD
@@ -0,0 +1,22 @@
1# Maintainer: Yigit Sever <yigit@yigitsever.com>
2
3pkgname=ryokucha
4pkgver=0.3.1
5pkgrel=1
6pkgdesc="A GTK4 library that includes customized widgets"
7arch=('x86_64')
8url="https://github.com/ryonakano/ryokucha"
9license=('LGPL-3.0-or-later')
10depends=('gtk4' 'pango')
11makedepends=('meson' 'vala')
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
13sha256sums=('503754d1a0a9012e5779f20ef1e9bb7db099eb9243bc98985b2136e4e1b0031e')
14
15build() {
16 arch-meson ${pkgname}-${pkgver} build
17 meson compile -C build
18}
19
20package() {
21 meson install -C build --destdir "${pkgdir}"
22}