summaryrefslogtreecommitdiffstats
path: root/reco/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'reco/PKGBUILD')
-rw-r--r--reco/PKGBUILD24
1 files changed, 0 insertions, 24 deletions
diff --git a/reco/PKGBUILD b/reco/PKGBUILD
deleted file mode 100644
index c4b4db0..0000000
--- a/reco/PKGBUILD
+++ /dev/null
@@ -1,24 +0,0 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3
4pkgname='reco'
5pkgver=5.0.0
6pkgrel=1
7pkgdesc='An audio recording app designed for elementary OS'
8arch=('x86_64')
9url='https://github.com/ryonakano/reco'
10license=('GPL3')
11depends=('granite7' 'gstreamer' 'libpulse' 'ryokucha' 'live-chart')
12makedepends=('meson' 'vala' 'libhandy')
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
14sha256sums=('87842098a4fe01effb0d374f689e025e91b8e906eedcaed4413694db73cd3595')
15
16build() {
17 arch-meson "${pkgname}-${pkgver}" build -Duse_submodule=false
18 meson compile -C build
19}
20
21package() {
22 DESTDIR="${pkgdir}" meson install -C build
23 install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}-${pkgver}/README.md"
24}